hdoj Clarke and five-pointed star 5563 (判断能否组成五角星)

Clarke and five-pointed star

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 566    Accepted Submission(s): 298


Problem Description
Clarke is a patient with multiple personality disorder. One day, Clarke turned into a learner of geometric.
When he did a research with polygons, he found he has to judge if the polygon is a five-pointed star at many times. There are 5 points on a plane, he wants to know if a five-pointed star existed with 5 points given.

Input
The first line contains an integer T(1T10) , the number of the test cases.
For each test case, 5 lines follow. Each line contains 2 real numbers xi,yi(109xi,yi109) , denoting the coordinate of this point.

Output
Two numbers are equal if and only if the difference between them is less than 104 .
For each test case, print Yes if they can compose a five-pointed star. Otherwise, print No . (If 5 points are the same, print Yes . )

Sample Input
  
  
2 3.0000000 0.0000000 0.9270509 2.8531695 0.9270509 -2.8531695 -2.4270509 1.7633557 -2.4270509 -1.7633557 3.0000000 1.0000000 0.9270509 2.8531695 0.9270509 -2.8531695 -2.4270509 1.7633557 -2.4270509 -1.7633557

Sample Output
  
  
Yes No
Hint

Source
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
double b[3100];
int map[310][310];
struct zz
{
	double x;
	double y;
}a[310];
int main()
{
	int t,i,j;
	scanf("%d",&t);
	while(t--)
	{
		for(i=0;i<5;i++)
			scanf("%lf%lf",&a[i].x,&a[i].y);
		int k=0;
		double mm=1.0*INF;
		memset(map,0,sizeof(map));
		for(i=0;i<5;i++)
		{
			for(j=i+1;j<5;j++)
			{
				if(map[i][j]||map[j][i])//消除重边 
					continue;
				b[k]=(a[i].x-a[j].x)*(a[i].x-a[j].x)+(a[i].y-a[j].y)*(a[i].y-a[j].y);
				mm=min(mm,b[k]);
				k++;
				map[i][j]=1;
			}
		}
		int num=0;
		for(i=0;i<k;i++)
			if(b[i]-mm<=1e-4)
				num++;
		if(num==5)
			printf("Yes\n");
		else
			printf("No\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值