UVA Calculator Conundrum 11549 (Floyd判环&数学&高效)

Calculator Conundrum

Alice got a hold of an old calculator that can display n digits. She was bored enough to come up withthe following time waster.

She enters a number k then repeatedly squares it until the result overflows. When the resultoverflows, only the n most significant digits are displayed on the screen and an error flag appears. Alicecan clear the error and continue squaring the displayed number. She got bored by this soon enough,but wondered:

“Given n and k, what is the largest number I can get by wasting time in this manner?”

Input

The first line of the input contains an integer t (1 ≤ t ≤ 200), the number of test cases. Each test casecontains two integers n (1 ≤ n ≤ 9) and k (0 ≤ k < 10n) where n is the number of digits this calculatorcan display k is the starting number.

Output

For each test case, print the maximum number that Alice can get by repeatedly squaring the startingnumber as described.

Sample Input2

1 6

2 99

Sample Output

9

99

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f3f
#define N 10010
#define ll long long
using namespace std;
int a[110];
int next(int n,int k)
{
	if(!k)
		return 0;
	ll k2=(ll)k*k;
	int l=0;
	while(k2>0)
	{
		a[l++]=k2%10;
		k2/=10;
	}
	if(n>l)
		n=l;
	int ans=0;
	for(int i=0;i<n;i++)
		ans=ans*10+a[--l];
	return ans;
} 
int main()
{
	int t,n,i,j,k;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&k);
		int ans=k;
		int k1=k;
		int k2=k;
		while(1)
		{
			k1=next(n,k1);//人1 
			k2=next(n,k2);//人2,第一步 
			if(k2>ans)
				ans=k2;
			k2=next(n,k2);//人2,第二步 
			if(k2>ans)
				ans=k2;
			if(k1==k2)//追上以后停止 
				break;
		}
		printf("%d\n",ans);
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值