UVA Find the Permutations 11077 (DP&置换群)

Find the Permutations

Sorting is one of the most used operations in real life, where Computer Science comes into act. It iswell-known that the lower bound of swap based sorting is nlog(n). It means that the best possiblesorting algorithm will take at least O(nlog(n)) swaps to sort a set of n integers. However, to sort aparticular array of n integers, you can always find a swapping sequence of at most (n − 1) swaps, onceyou know the position of each element in the sorted sequence.For example consider four elements <1 2 3 4>. There are 24 possible permutations and for allelements you know the position in sorted sequence.If the permutation is <2 1 4 3>, it will take minimum 2 swaps to make it sorted. If the sequenceis <2 3 4 1>, at least 3 swaps are required. The sequence <4 2 3 1> requires only 1 and the sequence<1 2 3 4> requires none. In this way, we can find the permutations of N distinct integers which willtake at least K swaps to be sorted.

Input

Each input consists of two positive integers N (1 ≤ N ≤ 21) and K (0 ≤ K < N) in a single line.Input is terminated by two zeros. There can be at most 250 test cases.

Output

For each of the input, print in a line the number of permutations which will take at least K swaps.

Sample Input

3 1

3 0

3 2

0 0

Sample Output

3

1

2

//题意:

给出两个数n,k,对1-n的所有序列进行两两交换,统计有多少个序列至少需要进行k次操作才能变成(1,2,......n)。

//思路:

看到这个题首先就会先到置换,单元素循环是不需要交换,两个元素循环要交换一次,.......n个元素循环要交换n-1次。

这样的话,如果序列的循环节为x,总共交换的次数为n-x次。所以可以退出下面:

用dp[i][j]表示至少要进行j次操作才能将1-i,这i个数排列为(1,2,......i)这样的序列的个数。

所以就会得到方程:dp[i][j]=dp[i-1][j-1]+f[i-1][j]*(i-1)。

因为元素i要么自己形成一个循环,要么加入到前面任意一个为。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f3f
#define ll unsigned long long
#define N 30
using namespace std;
int gcd(int a,int b)
{
	return b==0?a:gcd(b,a%b);
}
ll dp[N][N];
int init()
{
	int i,j;
	memset(dp,0,sizeof(dp));
	dp[1][0]=1;
	for(i=2;i<=21;i++)
	{
		for(j=0;j<i;j++)
		{
			dp[i][j]=dp[i-1][j];
			if(j>0)
				dp[i][j]+=dp[i-1][j-1]*(i-1);
		}
	}
}
int main()
{
	init();
	int n,k;
	while(scanf("%d%d",&n,&k),n|k)
	{
		printf("%llu\n",dp[n][k]);
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值