poj Big Number 1423 (数学 取对数&技巧)

Big Number
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 27526 Accepted: 8784

Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 <= m <= 10^7 on each line.

Output

The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input

2
10
20

Sample Output

7
19
//题意:
给你一个n,让你算出 n!的数的位数。
思路:
hdoj1018和这个题一样,直接对每个n取对数就行了,但这个题交上去竟然超时了。。。所以就转换成打表了,直接先将所有的(1--10000000)的值都打到数组a中,感觉挺快的,但是交上去超内存了。。。最后用打表和暴力结合,先打出(1--8000000)的值存到数组a中,如果n>8000000,那么在暴力求出从8000000--n之间的位数加上a[8000000],就行了。。。
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<iostream>
#define ll long long
#define ull unsigned long long
#define IN __int64
#define N 8000010
#define M 1000000007
using namespace std;
double a[N];
int init()
{
	a[0]=0;
	for(int i=1;i<N;i++)
	{
		a[i]=a[i-1]+log10(i);
	}
}
int count(int n)
{
	double m=a[N-1];
	for(int i=N;i<=n;i++)
		m+=log10(i);
	return (int)m+1;
}
int main()
{
	int t;
	int n,i;
	init();
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		if(n<N)
			printf("%d\n",(int)a[n]+1);
		else
			printf("%d\n",count(n));
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值