zoj Apples and Ideas (水)

Apples and Ideas

Time Limit: 2 Seconds Memory Limit: 65536 KB

"If you have an apple and I have an apple and we exchange these apples then you and I will still each have one apple. But if you have an idea and I have an idea and we exchange these ideas, then each of us will have two ideas." - George Bernard Shaw

Now Alice has A apples and B ideas, while Bob has C apples and D ideas, what will they have if they exchange all things?

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The only line contains four integers A, B, C, D (0 <= A, B, C, D <= 100) - as the problem described.

Output

For each test case, output two lines. First line contains two integers, indicating the number of Alice's apples and ideas; second line contains two integers, indicating the number of Bob's apples and ideas.

Sample Input
4
0 0 5 30
20 25 20 0
20 25 20 15
20 25 25 30
Sample Output
5 30
0 30
20 25
20 25
20 40
20 40
25 55
20 55
#include<stdio.h>
#include<string.h>
int main()
{
	int t,i,j;
	scanf("%d",&t);
	while(t--)
	{
		int a,b,c,d;
		int num1,num2,sum1,sum2;
		scanf("%d%d%d%d",&a,&b,&c,&d);
		num1=c;sum1=b+d;
		num2=a;sum2=b+d;
		printf("%d %d\n",num1,sum1);
		printf("%d %d\n",num2,sum2);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值