CodeForces - 584D Dima and Lisa (素数拆分)数学规律

85 篇文章 0 订阅
22 篇文章 0 订阅
CodeForces - 584D
Time Limit:                                                        1000MS                        Memory Limit:                                                        262144KB                        64bit IO Format:                            %I64d & %I64u                       

Status

Description

Dima loves representing an odd number as the sum of multiple primes, and Lisa loves it when there are at most three primes. Help them to represent the given number as the sum of at most than three primes.

More formally, you are given an odd numer n. Find a set of numbers pi (1 ≤ i ≤ k), such that

  1. 1 ≤ k ≤ 3
  2. pi is a prime

The numbers pi do not necessarily have to be distinct. It is guaranteed that at least one possible solution exists.

Input

The single line contains an odd number n (3 ≤ n < 109).

Output

In the first line print k(1 ≤ k ≤ 3), showing how many numbers are in the representation you found.

In the second line print numbers pi in any order. If there are multiple possible solutions, you can print any of them.

Sample Input

Input
27
Output
3
5 11 11

Sample Output

Hint

A prime is an integer strictly larger than one that is divisible only by one and by itself.

Source

//题意:给你一个奇数n
你可以见这个素数拆分成1,2或3个素数的和,将其输出,结果不唯一。
//思路:首先得知道一个数学规律,在小于10^9的素数中相邻两个素数之间的的距离不会超过300,。
知道上面的规律后解这个题就简单了。
通过分析我们可以知道:

1个:本身就是素数。

2个:因为给的是奇数,所以两个拆出来的数一定是一奇一偶,既是偶数又是素数的数只有2,所以我们只需判断n-2是否为素数即可。

3个:情况有两种:三个奇数,一奇二偶。

一奇二偶:二偶只能是2,2,所以判断n-4是否为奇数。

三个奇数:这就要用到前面的结论了。先找一个比n小的素数(尽量靠近n),根据上面的那个规律,所以我们就能很快的找到另一个素数。在做差以后得到x,剩下的两个数就在x里面暴力寻找即可。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<iostream>
using namespace std;
bool judge(int x)
{
	if(x==2||x==3) return true;
	else
	{
		for(int i=2;i<=sqrt(x);i++)
		{
			if(x%i==0)
				return false;
		}
		return true;
	}
}
int main()
{
	int n,m,i,j,k;
	while(scanf("%d",&n)!=EOF)
	{
		if(judge(n))
			printf("1\n%d\n",n);
		else if(judge(n-2))
			printf("2\n2 %d\n",n-2);
		else if(judge(n-4))
			printf("3\n2 2 %d\n",n-4);
		else
		{
			for(i=n-3;i>=n-300&&i>=1;i--)
			{
				if(judge(i))
				{
					k=i;
					break;
				}
			}
			m=n-i;
			if(judge(m))
				printf("2\n%d %d",m,k);
			else
			{
				for(i=2;i<=m;i++)
				{
					if(judge(i)&&judge(m-i))
					{
						printf("3\n%d %d %d\n",i,m-i,k);
						break;
					}
				}
			}
		}
	}
	return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值