ZOJ - 3876 May Day Holiday (打表&模拟)

40 篇文章 1 订阅
27 篇文章 0 订阅
ZOJ - 3876
Time Limit:                                                        2000MS                        Memory Limit: 65536KB 64bit IO Format:                            %lld & %llu                       

Status

Description

As a university advocating self-learning and work-rest balance, Marjar University has so many days of rest, including holidays and weekends. Each weekend, which consists of Saturday and Sunday, is a rest time in the Marjar University.

The May Day, also known as International Workers' Day or International Labour Day, falls on May 1st. In Marjar University, the May Day holiday is a five-day vacation from May 1st to May 5th. Due to Saturday or Sunday may be adjacent to the May Day holiday, the continuous vacation may be as long as nine days in reality. For example, the May Day in 2015 is Friday so the continuous vacation is only 5 days (May 1st to May 5th). And the May Day in 2016 is Sunday so the continuous vacation is 6 days (April 30th to May 5th). In 2017, the May Day is Monday so the vacation is 9 days (April 29th to May 7th). How excited!

Edward, the headmaster of Marjar University, is very curious how long is the continuous vacation containing May Day in different years. Can you help him?

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case, there is an integer y (1928 <= y <= 9999) in one line, indicating the year of Edward's query.

Output

For each case, print the number of days of the continuous vacation in that year.

Sample Input
3
2015
2016
2017
Output
5
6
9

Input

Output

Sample Input

Sample Output

Hint

Source

The 12th Zhejiang Provincial Collegiate Programming Contest
//题意:
输入一个数n,表示一个年份,每年的五一劳动节都会放假5天,但是若赶得的巧的话(连着周六周日一块),可能会放6天或者9天,问这一年五一会连着放几天假?
//思路:
通过找规律可以知道,若五一这一天是周一,那么,这一年可能放9天(连着前一个星期的周六周日和下一个星期的周六周日),若五一是周二或者是周日会放6天(递推和前面一样),其他的是放5天,知道这个规律,就可以做这个题了。
根据样例可知2015年五一是周五,2016是周日(遇到闰年,它的五一的星期会与上一年相差两天,平年的相差一天),2017是周一,所以根据这个可以打表。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
int a[10010];
int vis[10010];
int init()
{
	a[2015]=5;
	for(int i=2016;i<=10000;i++)
	{
		if(i%4==0&&i%100!=0||i%400==0)
			a[i]=(a[i-1]+2)%7;
		else
			a[i]=(a[i-1]+1)%7;
	}
	int k=5;
	for(int i=2015;i>=1928;i--)
	{
		if(i%4==0&&i%100!=0||i%400==0)
		{
			if(k>=2)
				a[i-1]=k-2;
			else
			{
				k=k+7;
				a[i-1]=k-2;
			}
			k-=2;
		}
		else
		{
			if(k>=1)
				a[i-1]=k-1;
			else
			{
				k+=7;
				a[i-1]=k-1;
			}
			k--;
		}
	}
}
int main()
{
	int t,n;
	init();
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		if(a[n]==1)
			printf("9\n");
		else if(a[n]==0||a[n]==2)
			printf("6\n");
		else
			printf("5\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值