hdoj ztr loves lucky numbers 5676 (dfs模拟)

133 篇文章 0 订阅
47 篇文章 1 订阅

ztr loves lucky numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 918    Accepted Submission(s): 389


Problem Description
ztr loves lucky numbers. Everybody knows that positive integers are lucky if their decimal representation doesn't contain digits other than 4 and 7. For example, numbers 47, 744, 4 are lucky and 5, 17, 467 are not.

Lucky number is super lucky if it's decimal representation contains equal amount of digits 4 and 7. For example, numbers 47, 7744, 474477 are super lucky and 4, 744, 467 are not.

One day ztr came across a positive integer n. Help him to find the least super lucky number which is not less than n.
 

Input
There are T (1n105)  cases

For each cases:

The only line contains a positive integer   n(1n1018) . This number doesn't have leading zeroes.
 

Output
For each cases
Output the answer
 

Sample Input
  
  
2 4500 47
 

Sample Output
  
  
4747 47
 

Source
问题描述
ztr喜欢幸运数字,他对于幸运数字有两个要求
1:十进制表示法下只包含4、7
2:十进制表示法下4和7的数量相等
比如47,474477就是
而4,744,467则不是

现在ztr想知道最小的但不小于n的幸运数字是多少
输入描述
T(1\leq\;T\leq\;10^{5})T(1T105)组数据,每组数据一个正整数nn1\leq\;n\leq\;10^{18}1n1018
输出描述
TT行,每行即答案
输入样例
2
4500
47
输出样例
4747
47
Hint
请尽可能地优化算法,考虑全面
//没啥说的,就是一个dfs模拟,但是得注意一个特判,见代码
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#define INF 0x3f3f3f3f
#define ll long long
#define N 100010
using namespace std;
ll a[N];
int cnt;
void dfs(int l,int r,int len,ll num)
{
	if(l>len/2||r>len/2) return ;
	if(l+r==len&&l==r)
	{
		a[cnt++]=num;
		return ;
	}
	if(l<=len/2) dfs(l+1,r,len,num*10+4);
	if(r<=len/2) dfs(l,r+1,len,num*10+7);
	
}
int main()
{
	cnt=0;
	for(int i=2;i<=18;i+=2)
		dfs(0,0,i,0);
	int t;
	ll n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lld",&n);
		if(n>777777777444444444ll)   //特判 
			printf("44444444447777777777\n");
		else
			printf("%lld\n",a[lower_bound(a,a+cnt,n)-a]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值