CodeForces - 675D Tree Construction (set&数据结构)

CodeForces - 675D
Time Limit: 2000MS Memory Limit: 262144KB 64bit IO Format: %I64d & %I64u

Status

Description

During the programming classes Vasya was assigned a difficult problem. However, he doesn't know how to code and was unable to find the solution in the Internet, so he asks you to help.

You are given a sequence a, consisting of ndistinct integers, that is used to construct the binary search tree. Below is the formal description of the construction process.

  1. First element a1 becomes the root of the tree.
  2. Elements a2, a3, ..., an are added one by one. To add element ai one needs to traverse the tree starting from the root and using the following rules:
    1. The pointer to the current node is set to the root.
    2. If ai is greater than the value in the current node, then its right child becomes the current node. Otherwise, the left child of the current node becomes the new current node.
    3. If at some point there is no required child, the new node is created, it is assigned value ai and becomes the corresponding child of the current node.

Input

The first line of the input contains a single integer n (2 ≤ n ≤ 100 000) — the length of the sequence a.

The second line contains n distinct integers ai (1 ≤ ai ≤ 109) — the sequence a itself.

Output

Output n - 1 integers. For all i > 1 print the value written in the node that is the parent of the node with value ai in it.

Sample Input

Input
3
1 2 3
Output
1 2
Input
5
4 2 3 1 6
Output
4 2 2 4

Sample Output

Hint

Source

//题意:
给你n个节点,第一个节点作为根节点,接下来的如果节点值>他的父节点,就将他练到他的右边,否则练到左边,输出从2--n节点的父节点的值。

//思路:
set模拟
#include<stdio.h>
#include<string.h>
#include<set>
#include<map>
#include<algorithm>
#include<iostream>
using namespace std;
set<int>t;
set<int>::iterator it;
set<int>::iterator it1;
set<int>::iterator it2;
map<int,int>pos;
int main()
{
	int n,x;	
	while(scanf("%d",&n)!=EOF)
	{
		t.clear();
		int T=1;
		scanf("%d",&x);
		t.insert(0);t.insert(x);
		pos[x]=T++;
		while(T<=n)
		{
			scanf("%d",&x);
			it=t.lower_bound(x);			
			it1=it--;it2=it;
			if(pos[*it1]<pos[*it2])
				printf("%d ",*it2);				
			else
				printf("%d ",*it1);
			t.insert(x);
			pos[x]=T++;
		} 
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值