1060. Are They Equal (25)

题目:

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line "YES" if the two numbers are treated equal, and then the number in the standard form "0.d1...dN*10^k" (d1>0 unless the number is 0); or "NO" if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:
3 12300 12358.9
Sample Output 1:
YES 0.123*10^5
Sample Input 2:
3 120 128
Sample Output 2:
NO 0.120*10^3 0.128*10^3
注意:
1、思路是找到第一个有效数字的位置和小数点的位置(注意如果没有出现小数点就认为小数点在最后一位的后面)。
2、由这两个位置就可以计算出10的指数项数值。
3、注意当输入数字的有效位数不够时要在低位填0。

代码:
#include<iostream>
#include<cstring>
using namespace std;

int main()
{
	int k[2],n;
	char a[2][105],b[2][105];
	scanf("%d%s%s",&n,a[0],a[1]);
	int len[2]={strlen(a[0]),strlen(a[1])};
	for(int i=0;i<2;++i)
	{
		int firstdigit=-1,dot=len[i],count=0;
		for(int j=0;j<len[i];++j)
		{//check every char in the input string
			if(firstdigit<0 && a[i][j]>'0' && a[i][j]<='9')
			{//if it is the first significant digit 
				firstdigit=j;
				b[i][count++]=a[i][j];
			}
			else if(firstdigit>=0 && count<n && a[i][j]!='.')
				b[i][count++]=a[i][j];
			if(a[i][j]=='.')//find the position of dot
				dot=j;
		}
		//if the digit lenght of input isn't enough, '0' need to be fullfilled to back
		if(count<n)
			while(count<n)
				b[i][count++]='0';
		b[i][count]='\0';
		if(firstdigit>=0)
			k[i]=dot>firstdigit?dot-firstdigit:dot-firstdigit+1;
		else k[i]=0;//that means a[i]="0"
	}
	if(strcmp(b[0],b[1])==0 && k[0]==k[1])
		printf("YES 0.%s*10^%d\n",b[0],k[0]);
	else
		printf("NO 0.%s*10^%d 0.%s*10^%d\n",b[0],k[0],b[1],k[1]);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值