1068. Find More Coins (30)

题目:

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 104 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=104, the total number of coins) and M(<=102, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V1 <= V2 <= ... <= Vk such that V1 + V2 + ... + Vk = M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.

Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k >= 1 such that A[i]=B[i] for all i < k, and A[k] < B[k].

Sample Input 1:
8 9
5 9 8 7 2 3 4 1
Sample Output 1:
1 3 5
Sample Input 2:
4 8
7 2 4 3
Sample Output 2:
No Solution

注意:
1、这是一个典型的背包问题,需要使用动态规划来完成,更加详细的资料大家可以参考百度百科的背包问题或者崔添翼的《背包问题九讲》。
2、本题是要从所有硬币中选择出数值加起来等于某一值的组合,等同于已知某一容量的背包要求从物品中选择一个组合使得总体积最大,只不过本题要求这个组合的体积要刚好等于背包的容量罢了。
3、这里描述一下背包问题:
     有N件物品和一个容量为V的背包。第i件物品的重量是w[i],价值是v[i]。求解将哪些物品装入背包可使这些物品的重量总和不超过背包容量,且价值总和最大。
     用子问题定义状态:即f[i][v]表示前i件物品恰放入一个容量为v的背包可以获得的最大价值。则其状态转移方程便是:
                                   f[i][v]=max{ f[i-1][v], f[i-1][v-w[i]]+v[i] }。
     可以压缩空间的状态转移方程为:
                                           f[v]=max{f[v],f[v-w[i]]+v[i]}
4、我自己用第二种方法case4一直都无法通过,调了很久也没有成功。正确的代码大家可以参考我觉得比较好的人间天堂的blog:http://blog.csdn.net/tiantangrenjian/article/details/17334201。
5、下面是我自己写的未能ac的代码。

代码:
//1068  case 4 is not passed
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int main()
{
	int n,m;
	scanf("%d%d",&n,&m);
	vector<int>coins;
	coins.resize(n+1);
	for(int i=1;i<=n;++i)
		scanf("%d",&coins[i]);
	sort(++coins.begin(),coins.end(),greater<int>());
	//cap[j] means the max coin value with the capacity j
	int cap[105]={0};
	int solu[1005][105]={0};
	for(int i=1;i<=n;++i)
	{
		for(int j=m;j>=coins[i];--j)
			if(cap[j-coins[i]]+coins[i]>=cap[j])
			{
				cap[j]=cap[j-coins[i]]+coins[i];
				solu[j][i]=1;
			}
	}
	if(cap[m]!=m)
		printf("No Solution\n");
	else
	{//print the solution
		int first=1;
		for(int i=n;i>0 && m>0;--i)
		{
			if(solu[m][i])
			{
				if(first)
					first=0;
				else
					printf(" ");
				printf("%d",coins[i]);
				m -= coins[i];
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值