hdu 1326 java (理解起来很简单)

点击打开链接

Box of Bricks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5841    Accepted Submission(s): 2536


Problem Description
Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you should make all stacks the same height. Then you would have a real wall.'', she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help? 


 

Input
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height. 

The input is terminated by a set starting with n = 0. This set should not be processed. 
 

Output
For each set, first print the number of the set, as shown in the sample output. Then print the line ``The minimum number of moves is k.'', where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height. 

Output a blank line after each set.
 

Sample Input
  
  
6 5 2 4 1 7 5 0
 

Sample Output
  
  
Set #1 The minimum number of moves is 5.
 

Source
 
题目解释:
题目意思很简单,就是 给你n个数,然后通过编程变成n个都相等的数,问求怎么移动的最小数目,然后按题目的要求输出。每一个输出之后都要换一行(这里地方我PE了很多次),大家注意点就好。
package cn.hncu.acm;

import java.util.Scanner;

public class p1326 {

	public static void main(String[] args) {
			Scanner sc =new Scanner(System.in);//从键盘收数
			int d=0;
			while(sc.hasNext()){
			int n=sc.nextInt();//输入n
			if(n==0){
				break;
			}
			int a[]=new int[n];//用来放n个数
			int sun=0,m=0;
			for(int i=0;i<n;i++){
				a[i]=sc.nextInt();
				sun=sun+a[i];//求n个数的和,求平均数
			}
			sun=sun/n;//求平均数
			
			//当求出平均数后,比平均数多出来的就必须移动其他的地方,也就是不会重复移动,也就是最少的移动路径
			for(int i=0;i<n;i++){
				if(a[i]>sun){
					m=m+a[i]-sun;//求多出来的数字
					
				}
			}
			d=d+1;//为目标输出 SEt # d
			System.out.println("Set #"+d);
			System.out.println("The minimum number of moves is "+m+".");
			System.out.println();//PE 是因为 最后没有换行
	}
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值