HDU 2058 The sum problem

The sum problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20835    Accepted Submission(s): 6140


Problem Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
 

Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
 

Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.
 

Sample Input
  
  
20 10 50 30 0 0
 

Sample Output
  
  
[1,4] [10,10] [4,8] [6,9] [9,11] [30,30]
 

Author
8600
 

Source
 

Recommend

linle   |   We have carefully selected several similar problems for you:  2059 2056 2057 2062 2060 

数学知识等差数列的应用,刚开始做时是直接从1~n,一一进行相加列举,结果超时了,后来才知道是等差数列的应用

sum=(a+a+d)*d/2

#include<stdio.h>
#include<math.h>
int main()
{
 int N,M,i,n,m;
 while(scanf("%d%d",&N,&M),N||M)
 {
  n=sqrt((double)(M)*2);
  while(n)
  {
   m=M/n-(n-1)/2;
   if(m*n+(n*(n-1)/2)==M)
    printf("[%d,%d]\n",m,m+n-1);
   n--;
  }
  printf("\n");
 }
 return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值