POJ 2082 Terrible Sets (栈)

Terrible Sets
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 4350 Accepted: 2250

Description

Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some elements in N, and w0 = 0. 
Define set B = {< x, y > | x, y ∈ R and there exists an index i > 0 such that 0 <= y <= hi ,∑ 0<=j<=i-1wj <= x <= ∑ 0<=j<=iwj} 
Again, define set S = {A| A = WH for some W , H ∈ R + and there exists x0, y0 in N such that the set T = { < x , y > | x, y ∈ R and x0 <= x <= x0 +W and y0 <= y <= y0 + H} is contained in set B}. 
Your mission now. What is Max(S)? 
Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy. 
But for this one, believe me, it's difficult.

Input

The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an single integer -1, indicating the end of input. You may assume that 1 <= n <= 50000 and w 1h 1+w 2h 2+...+w nh n < 10 9.

Output

Simply output Max(S) in a single line for each case.

Sample Input

3
1 2
3 4
1 2
3
3 4
1 2
3 4
-1

Sample Output

12
14

Source

题意:有一排矩形靠在一起,问这些矩形能组成的最大矩形
维护一个栈中元素高度单调递增的栈,初始化栈中第一个元素高度宽度均为0,
然后每次读入一个矩形,若它比栈顶元素还高就直接进栈,
否则不断将栈中元素弹栈,直到当前栈顶元素能够与读入的矩形满足高度递增。
弹栈过程中累加弹出的元素的宽度,然后每弹出一个就判断当前弹出元素的高度×
累加的宽度能否更新最大面积ans。然后以新的矩形作高,
已经弹出栈的元素总宽度加上新矩形宽度作宽,把这个矩形插入到栈里。
最终栈肯定是一个单调的,只需要再把栈一个个弹空,弹栈过程中仍像上面那样计算即可。
#include<stdio.h>
#include<stack>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
	int w,h;
}t;
int main()
{
	int n,i,j,k,l;
	while(scanf("%d",&n)&&n!=-1)
	{
		stack<node>s;
		int width,ans=0,area,last=0;
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&t.w,&t.h);
		    if(t.h>=last)//如果要进栈的元素大于等于栈顶元素,直接进栈 
		    s.push(t);
		    else
		    {
			   width=0;
			   while(!s.empty()&&s.top().h>t.h)//如果要进栈的元素小于栈顶的元素,栈顶的元素出栈 
			   {
				  width+=s.top().w;
				  area=width*s.top().h;//计算出栈元素组成的最大面积 
				  if(area>ans)
				  ans=area;
				  s.pop(); 
			   }
			   width+=t.w;//将出栈元素与进栈的元素合并的宽为宽,取进栈元素的高为高,进栈 
			   t.w=width;
			   s.push(t);
		    }
		    last=t.h;
		}
		width=0;
		while(!s.empty())//将栈内元素全部遍历一遍 
		{
			width+=s.top().w;
			area=width*s.top().h;
			if(area>ans)
			ans=area;
			s.pop();
		}
		printf("%d\n",ans);
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值