HDU 5211 Mutiple

Mutiple

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 915    Accepted Submission(s): 547


Problem Description
WLD likes playing with a sequence  a[1..N] . One day he is playing with a sequence of  N  integers. For every index i, WLD wants to find the smallest index  F(i)  ( if exists ), that  i<F(i)n , and  aF(i)  mod  ai  = 0. If there is no such an index  F(i) , we set  F(i)  as 0.
 

Input
There are Multiple Cases.(At MOST  10 )

For each case:

The first line contains one integers  N(1N10000) .

The second line contains  N  integers  a1,a2,...,aN(1ai10000) ,denoting the sequence WLD plays with. You can assume that all ai is distinct.
 

Output
For each case:

Print one integer.It denotes the sum of all  F(i)  for all  1i<n
 

Sample Input
  
  
4 1 3 2 4
 

Sample Output
  
  
6
Hint
F(1)=2 F(2)=0 F(3)=4 F(4)=0
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5906  5905  5903  5902  5901 
做题前一定要读清题。。。。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0xfffffff
using namespace std;
int a[11000],b[110000];
int main()
{
	int n,i,j,k,flag;
	while(scanf("%d",&n)!=EOF)
	{
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			b[a[i]]=i;
		}
		int ans=0;
		for(i=1;i<=n;i++)
		{
			k=INF;
			for(j=2;j*a[i]<=n;j++)
			{
				if(b[j*a[i]]&&b[j*a[i]]>i)
				{
					k=min(k,b[j*a[i]]);
				}
			}
			if(k!=INF)
			ans+=k;
		}
		printf("%d\n",ans);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值