HDU 5491 The Next

The Next

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1781    Accepted Submission(s): 672


Problem Description
Let  L  denote the number of 1s in integer  D ’s binary representation. Given two integers  S1  and  S2 , we call  D  a WYH number if  S1LS2 .
With a given  D , we would like to find the next WYH number  Y , which is JUST larger than  D . In other words,  Y  is the smallest WYH number among the numbers larger than  D . Please write a program to solve this problem.
 

Input
The first line of input contains a number  T  indicating the number of test cases ( T300000 ).
Each test case consists of three integers  D S1 , and  S2 , as described above. It is guaranteed that  0D<231  and  D  is a WYH number.
 

Output
For each test case, output a single line consisting of “Case #X: Y”.  X  is the test case number starting from 1.  Y  is the next WYH number.
 

Sample Input
  
  
3 11 2 4 22 3 3 15 2 5
 

Sample Output
  
  
Case #1: 12 Case #2: 25 Case #3: 17
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5932  5931  5930  5929  5928 
 
题意:找到一个最小的大于D的数,使它的二进制中1的个数在s1~s2之间。
思路:从D+1开始找,如果1的个数小于s1,的数y,将y的二进制位从左到右0的变为1,最后转化为十进制,如果1的个数大于s2跳过
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define LL __int64
using namespace std;
LL tol,t,s1,s2,d[44],f;
LL get(LL x)//将x转化为二进制,并计算X的二进制中1的个数 
{
	LL num=0,t=0;
	while(x)
	{
		d[t++]=x%2;
		if(x&1)
		{
			num++;
		}
		x=x/2;
	}
	return num;
}
int main()
{
	LL T,D,i,j,k,cant=1;
	scanf("%I64d",&T);
	while(T--)
	{
		memset(d,0,sizeof(d));
		scanf("%I64d%I64d%I64d",&D,&s1,&s2);
		LL y,dis=0;
		LL sum;
		do
		{
			dis++;//从D+1开始找 
			y=D+dis;
			sum=get(y);
			if(sum<s1)
			{
				LL add=s1-sum;
				j=0;
				while(add)
				{
					if(d[j]==0)
					{
						d[j]=1;
						add--;
					}
					j++;
				}
				break;
			}
		}while(sum<s1||sum>s2);
		LL ans=0,temp=1;
		for(i=0;i<40;i++)
		{
			if(d[i])
				ans+=temp;
			temp<<=1;
		}
		printf("Case #%I64d: ",cant++);
		printf("%I64d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值