HDU 5491(模拟)

The Next

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 817    Accepted Submission(s): 322


Problem Description
Let  L  denote the number of 1s in integer  D ’s binary representation. Given two integers  S1  and  S2 , we call  D  a WYH number if  S1LS2 .
With a given  D , we would like to find the next WYH number  Y , which is JUST larger than  D . In other words,  Y  is the smallest WYH number among the numbers larger than  D . Please write a program to solve this problem.
 

Input
The first line of input contains a number  T  indicating the number of test cases ( T300000 ).
Each test case consists of three integers  D S1 , and  S2 , as described above. It is guaranteed that  0D<231  and  D  is a WYH number.
 

Output
For each test case, output a single line consisting of “Case #X: Y”.  X  is the test case number starting from 1.  Y  is the next WYH number.
 

Sample Input
  
  
3 11 2 4 22 3 3 15 2 5
 

Sample Output
  
  
Case #1: 12 Case #2: 25 Case #3: 17
 

//当时网络赛只做出一题 真是弱爆了 。。 直接模拟
//从右到左遍历遇到1变为0  遇到0时判断一下
#include <stdio.h>
#include <string.h>
bool bin[100];
int main()
{
    int t,tt=1;
    scanf("%d",&t);
    while(t--)
    {
        int n,l,r,cnt=0;
        memset(bin,0,sizeof(bin));
        int cn,cnn,flag=0; //cn 1 的个数 cnn 变为0的个数 flag 判断是否需要从头补1
        cn=cnn=0;
        scanf("%d%d%d",&n,&l,&r);
        while(n)
        {
            bin[cnt++]=n%2;
            n/=2;
            if(bin[cnt-1]==1)
                cn++;
        }
        bin[cnt]=0;
        for(int i=0;i<=cnt;i++)
        {
            if(bin[i]==1)
            {
                cnn++;
                bin[i]=0;
            }
            else
            {
                if(cn-cnn+1>=l&&cn-cnn+1<=r)
                {
                    bin[i]=1;
                    break;
                }
                else if(cn-cnn+1<l)
                {
                    flag=1;
                    bin[i]=1;
                    break;
                }
            }
        }
        if(flag)  //个数不足补0
        {
            for(int i=0;i<l-(cn-cnn+1);i++)
                bin[i]=1;
        }
        __int64 res=1,ans=0;  //注意64位
        for(int i=0;i<=cnt;i++)
        {
            if(bin[i])
                ans+=res;
            res*=2;
        }
        printf("Case #%d: ",tt++);
        printf("%I64d\n",ans);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值