hdu 5491

The Next

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 886    Accepted Submission(s): 367


Problem Description
Let L denote the number of 1s in integer D ’s binary representation. Given two integers S1 and S2 , we call D a WYH number if S1LS2 .
With a given D , we would like to find the next WYH number Y , which is JUST larger than D . In other words, Y is the smallest WYH number among the numbers larger than D . Please write a program to solve this problem.
 

Input
The first line of input contains a number T indicating the number of test cases ( T300000 ).
Each test case consists of three integers D , S1 , and S2 , as described above. It is guaranteed that 0D<231 and D is a WYH number.
 

Output
For each test case, output a single line consisting of “Case #X: Y”. X is the test case number starting from 1. Y is the next WYH number.
 

Sample Input
  
  
3 11 2 4 22 3 3 15 2 5
 

Sample Output
  
  
Case #1: 12 Case #2: 25 Case #3: 17
 

Source

分析:这题很重要的一点是会爆int,所以要用long long

这题暴力枚举就好了,从d+1开始枚举,分成二进制,计算一的个数,如果1的个数大于s2,那么跳过,如果小于s1,那么从低位开始,把0变成1,直到1的个数等于s1,break

如果大于s1,小于s2,找到解,结束,最后把二进制转换成十进制。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define LL long long
using namespace std;
int a[35];
LL ans,tot,num,d,n,s1,s2;
int main()
{
    int T;
  //  freopen("f.txt","r",stdin);
    scanf("%d",&T);
    int cas=0;
    while(T--){
        memset(a,0,sizeof(a));
        scanf("%lld%lld%lld",&d,&s1,&s2);
        do{
            d++;
            n=d;
            num=tot=0;
            while(n){
                if(n&1){
                    a[num]=1;
                    tot++;
                }
                else a[num]=0;
                num++;
                n>>=1;
            }
            if(tot<s1){
                LL add=s1-tot;
                LL j=0;
                while(add){
                    if(a[j]==0){
                        a[j]=1;
                        add--;
                    }
                    j++;
                }
                break;
            }

        }while(tot>s2);
        ans=0;
        LL t=1;
        for(int i=0;i<=num+1;i++){
            if(a[i])ans+=t;
            t<<=1;
        }
        printf("Case #%d: %lld\n",++cas,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值