1051 - My-graph
Time Limit:1s Memory Limit:64MByte
Submissions:350Solved:170
DESCRIPTION
In graph theory, the inverse of a graph GG is a graph HH on the same vertices such that two distinct vertices of HH are adjacent if and only if they are not adjacent in GG.
My-graph is the graph that it's inverse graph is an isomorphism graph of itself.
(This is a example of My-graph has 5 nodes).
Now comes the problem: Do you have a way to make a My-graph that has nn nodes?
INPUT
There are multiple test cases.The first line is a number T (
T ≤100T ≤100), which means the number of cases.For each case, one integer
n(2≤n≤104)n(2≤n≤104) means the nodes you have initially.
OUTPUT
If you have at least one way to make it , please output "yes".If there is no way, output "no".
SAMPLE INPUT
225
SAMPLE OUTPUT
noyes
SOLUTION
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
int t,n,m,i,j;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
m=n*(n-1)/2;
if(m%2)
printf("no\n");
else
printf("yes\n");
}
return 0;
}