HDU 5971 Wrestling Match(染色体法判断二分图)

Wrestling Match

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 375    Accepted Submission(s): 176


Problem Description
Nowadays, at least one wrestling match is held every year in our country. There are a lot of people in the game is "good player”, the rest is "bad player”. Now, Xiao Ming is referee of the wrestling match and he has a list of the matches in his hand. At the same time, he knows some people are good players,some are bad players. He believes that every game is a battle between the good and the bad player. Now he wants to know whether all the people can be divided into "good player" and "bad player".
 

Input
Input contains multiple sets of data.For each set of data,there are four numbers in the first line:N (1 ≤ N≤ 1000)、M(1 ≤M ≤ 10000)、X,Y(X+Y≤N ),in order to show the number of players(numbered 1toN ),the number of matches,the number of known "good players" and the number of known "bad players".In the next M lines,Each line has two numbersa, b(a≠b) ,said there is a game between a and b .The next line has X different numbers.Each number is known as a "good player" number.The last line contains Y different numbers.Each number represents a known "bad player" number.Data guarantees there will not be a player number is a good player and also a bad player.
 

Output
If all the people can be divided into "good players" and "bad players”, output "YES", otherwise output "NO".
 

Sample Input
  
  
5 4 0 0 1 3 1 4 3 5 4 5 5 4 1 0 1 3 1 4 3 5 4 5 2
 

Sample Output
  
  
NO YES
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5981  5980  5979  5978  5977 
 
题意:有N个选手,问能否把这些人全部分为好选手和选手,其中给出M场比赛,每场比赛有一个好选手,一个坏选手,有X个好选手的序号已知,有Y个坏选手的序号已知
思路:染色法判断是否能成为二分图,即给每位选手染上色,判断染色是否矛盾
#include<stdio.h>
#include<vector>
#include<string.h>
#include<algorithm>
#define MAX  1005
using namespace std;
vector<int>G[MAX];
int color[MAX];
int N,M,X,Y;
bool DFS(int v,int c)
{
	int i,j;
	color[v]=c;
	for(i=0;i<G[v].size();i++)
	{
		if(color[G[v][i]]==c)
		    return false;
		if(color[G[v][i]]==0&&!DFS(G[v][i],-c))
		    return false;
	}
	return true;
}
void solve()
{
	int i,j;
	for(i=0;i<N;i++)
	{
		
		if(color[i]==1)
		{
			if(!DFS(i,1))
			{
				printf("NO\n");
				return ;
			}
		}
		else if(color[i]==-1)
		{
			if(!DFS(i,-1))
			{
				printf("NO\n");
				return ;
			}
		} 
	}
	for(i=0;i<N;i++)
	{
		if(color[i]==0)
		{
			if(!DFS(i,1))
			{
				printf("NO\n");
				return ;
			}
		}
	}
	for(i=0;i<N;i++)
	{
		if(color[i]==-5)
		{
			printf("NO\n");
			return ;
		}
	}
	printf("YES\n");
}
int main()
{
	int a,b,i,j;
	while(scanf("%d%d%d%d",&N,&M,&X,&Y)!=EOF)
	{
		for(i=0;i<N;i++)
		{
			G[i].clear();
			color[i]=-5;
		}
		for(i=0;i<M;i++)
		{
			scanf("%d%d",&a,&b);
			a--;
			b--;
			color[a]=0;
			color[b]=0;
			G[a].push_back(b);
			G[b].push_back(a);
		}
		for(i=0;i<X;i++)
		{
			scanf("%d",&a);
			a--;
			color[a]=1;
		}
		for(i=0;i<Y;i++)
		{
			scanf("%d",&a);
			a--;
			color[a]=-1;
		}
		solve();
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值