HDU5971 Wrestling Match(二分图的判断)

Wrestling Match

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1027    Accepted Submission(s): 388


Problem Description
Nowadays, at least one wrestling match is held every year in our country. There are a lot of people in the game is "good player”, the rest is "bad player”. Now, Xiao Ming is referee of the wrestling match and he has a list of the matches in his hand. At the same time, he knows some people are good players,some are bad players. He believes that every game is a battle between the good and the bad player. Now he wants to know whether all the people can be divided into "good player" and "bad player".
 

Input
Input contains multiple sets of data.For each set of data,there are four numbers in the first line:N (1 ≤ N≤ 1000)、M(1 ≤M ≤ 10000)、X,Y(X+Y≤N ),in order to show the number of players(numbered 1toN ),the number of matches,the number of known "good players" and the number of known "bad players".In the next M lines,Each line has two numbersa, b(a≠b) ,said there is a game between a and b .The next line has X different numbers.Each number is known as a "good player" number.The last line contains Y different numbers.Each number represents a known "bad player" number.Data guarantees there will not be a player number is a good player and also a bad player.
 

Output
If all the people can be divided into "good players" and "bad players”, output "YES", otherwise output "NO".
 

Sample Input
  
  
5 4 0 0 1 3 1 4 3 5 4 5 5 4 1 0 1 3 1 4 3 5 4 5 2
 

Sample Output
  
  
NO YES
 

Source

思路:这个题目表达的意思有点模糊,从事例上来说,题目让求得是能否把给定的顶点完全分成两个集合,即一部分分成good,一部分分成bad,这样就是判断给定的边能否成为一个二分图。


#include <cstdio>
#include <vector>
#include <cstring>
using namespace std;

int n,m,x,y,color[1005],vis[1005];
vector<int>p[1005];

int dfs(int u){
	for(int i = 0; i < p[u].size(); i ++){//对以该顶点为头的链表进行判断 
		int v = p[u][i];//取其中的节点 
		if(!color[v]){//当前点是未知点 
			color[v] = !color[u];//为头节点的相反状态 
			if(!dfs(v))//判断是否存在与v节点相矛盾的顶点 
				return 0;
		}
		else if(color[v] == color[u]){//两顶点的状态一致 
			return 0;
		}
	}
	return 1;
}

int main(){
	while(~scanf("%d%d%d%d",&n,&m,&x,&y)){
		for(int i = 0; i <= 1000; i ++)//对数组进行清零 
			p[i].clear();
		memset(color,0,sizeof(color));
		memset(vis,0,sizeof(vis));
		int a,b;
		for(int i = 0; i < m; i ++){
			scanf("%d%d",&a,&b);
			p[a].push_back(b);//把b放在a的后面 
			vis[a] = vis[b] = 1;//对出现的元素进行标记 
		}
		for(int i = 0; i < x; i ++){
			scanf("%d",&a);
			color[a] = vis[a] = 1;//对确定是good的顶点进行标记 
		}
		for(int i = 0; i < y; i ++){//对于bad的顶点可以作为位置顶点来判断,因为就两个集合 
			scanf("%d",&a);
			vis[a] = 1;
		}
	
		int cnt = 0;
		for(int i = 1; i <= n; i ++){//计算出新的顶点数目 
			if(vis[i])
				cnt ++;
		}
		if(n == 1 || cnt < n){//顶点数目为1或者出现的顶点数小于n,则输出NO 
			printf("NO\n");
			continue;
		}
		int flag = 1;
		for(int i = 1; i <= n; i ++){
			if(!dfs(i)){//判断是否存在与其相矛盾的顶点 
				flag = 0;
				break;
			}
		}
		if(flag)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值