ZOJ1002 FIRE NET

Description:

Suppose that we have a square city with straight streets. A map of a city is a squareboard with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand,a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city aspossible so that no two can destroy each other. A configuration ofblockhouses islegal provided that no two blockhouses are on the samehorizontal row or vertical column in a map unless there is at least one wallseparating them. In this problem we will consider small square cities (at most 4x4) that contain walls through whichbullets cannot run through.

The following image shows five pictures of the same board. Thefirst picture is the empty board, the second and third pictures show legalconfigurations, and the fourth and fifth pictures show illegal configurations.For this board, the maximum number of blockhouses in a legal configurationis 5; the second picture shows one way to do it, but there are severalother ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in thecity in a legal configuration.

The input file contains one or more map descriptions, followed bya line containing the number 0 that signals the end of the file. Eachmap description begins with a line containing a positive integernthat is the size of the city; n will be at most 4. The next nlines each describe one row of the map, with a '.' indicating anopen space and an uppercase 'X' indicating a wall. There are nospaces in the input file.

For each test case, output one line containing themaximum number of blockhouses that can be placed in the cityin a legal configuration.

Sample input:

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample output:

5
1
5
2
4


代码:

#include <stdio.h>
#include <stdlib.h>

char city[4][4];
int n;
int max = 0;
int temp = 0;

int test(int x,int y)
{
    int i;
    for(i = y;i < n;i++)
    {
        if(city[x][i] == 'o')
            return 0;
        if(city[x][i] == 'X')
            break;
    }
    for(i = y;i >= 0;i--)
    {
        if(city[x][i] == 'o')
            return 0;
        if(city[x][i] == 'X')
            break;
    }
    for(i = x;i < n;i++)
    {
        if(city[i][y] == 'o')
            return 0;
        if(city[i][y] == 'X')
            break;
    }
    for(i = x;i >= 0;i--)
    {
        if(city[i][y] == 'o')
            return 0;
        if(city[i][y] == 'X')
            break;
    }

    return 1;
}

void DFS()
{
    if(temp > max)
        max = temp;
    int i,j;
    for(i = 0;i < n;i++)
        for(j = 0;j < n;j++)
            {
                if(city[i][j] == '.' && test(i,j))
                {
                    temp++;
                    city[i][j] = 'o';
                    DFS();
                    temp--;
                    city[i][j] = '.';
                }
            }
}

int main()
{
    scanf("%d",&n);
    while(n != 0)
    {
        int i,j;
        max = 0;
        temp = 0;
        char t[6];
        for(i = 0;i < n;i++)
        {
            scanf("%s",t);
            for(j = 0;j < n;j++)
                city[i][j] = t[j];
        }
        DFS();
        printf("%d\n",max);
        scanf("%d",&n);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值