Traffic HDU-6573

See the original article https://dyingdown.github.io/2019/11/11/Traffic/

Traffic

Problem

Avin is observing the cars at a crossroads. He finds that there are n cars running in the east-west direction with the i-th car passing the intersection at time ai . There are another m cars running in the north-south direction with the i-th car passing the intersection at time bi . If two cars passing the intersections at the same time, a traffic crash occurs. In order to achieve world peace and harmony, all the cars running in the north-south direction wait the same amount of integral time so that no two cars bump. You are asked the minimum waiting time.

Input

The first line contains two integers n and m (1 ≤ n, m ≤ 1, 000). The second line contains n distinct integers ai (1 ≤ ai ≤ 1, 000). The third line contains m distinct integers bi (1 ≤ bi ≤ 1, 000).

Output

Print a non-negative integer denoting the minimum waiting time.

Sample Input

1 1
1
1
1 2
2
1 3

Sample Output

1
0

Analysis

There is a fuzzy point in the description. That is all the car has to wait the same amount of time. For example:

dir\min123456
east-west134
north-south125

The north-south cars has a car go through minute 1 and is conflict with the east-west car. So it has to wait a minute. But all the cars has to wait the same amount of time. So the situation looks like this:

dir\min123456
east-west134
north-south236

However there is still a confliction at minute 3. So wait another minute.

dir\min1234567
east-west134
north-south347

Now there are two conflictions. We keep waiting another minute.

dir\min12345678
east-west134
north-south458

Ah—!Another minute.

dir\min123456789
east-west134
north-south569

Finally, all the cars can pass without confliction.

The code is to stimulate this process to find the least waiting minute.

Code

#include<bits/stdc++.h>

using namespace std;

int a[100000], b[100000];
int main() {
	int n, m, s;
	cin >> n >> m;
	for(int i = 0; i < n; i ++){
		cin >> s;
		a[s] = 1;
	}
	for(int i = 0; i < m; i ++){
		cin >> b[i];
	}
	int t = 0;
	while(1) {
		int flag = 0;
		for(int i = 0; i < m; i ++){
			if(a[b[i] + t] != 0){
				flag = 1;
				break;
			}
		}
		if(flag) {
			t ++;
		} else {
			break;
		}
	}
	cout << t << endl;
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值