Traffic HDU - 6573

Avin is observing the cars at a crossroads. He finds that there are n cars running in the east-west direction with the i-th car passing the intersection at time ai . There are another m cars running in the north-south direction with the i-th car passing the intersection at time bi . If two cars passing the intersections at the same time, a traffic crash occurs. In order to achieve world peace and harmony, all the cars running in the north-south direction wait the same amount of integral time so that no two cars bump. You are asked the minimum waiting time.
Input
The first line contains two integers n and m (1 ≤ n, m ≤ 1, 000). The second line contains n distinct integers ai (1 ≤ ai ≤ 1, 000). The third line contains m distinct integers bi (1 ≤ bi ≤ 1, 000).
Output
Print a non-negative integer denoting the minimum waiting time.
Sample Input
1 1
1
1
1 2
2
1 3
Sample Output
1
0

题意:

一个十字路口,从东往西有n辆车,从南往北有m辆车,给你每辆车通过路口的时刻,如果两边的车在同一个时刻到达路口就会相撞,所以现在要让从南向北的车都在路口停留一段时间,保证所有车都不会和从东往西的车相撞,求出最小的停留时间t;

思路;

让t从0开始递增,然后遍历从南向北的车,时间都加上t,看是否和从东往西的车起冲突;得到的t一定是最小的;

#include <bits/stdc++.h>
using namespace std;
int a[100010],b[100010];
map<int,int> mp;
int main()
{
	int n,m;
	scanf("%d %d",&n,&m);
	for(int i=0;i<n;i++) scanf("%d",&a[i]),mp[a[i]]++;
	for(int i=0;i<m;i++) scanf("%d",&b[i]);
	int flag=0;
	for(int i=0;;i++)
	{
		flag=0;
		for(int j=0;j<m;j++)
		{
			int x=b[j]+i;
			if(mp[x])
			{
				flag=1;
				break;
			}
		}
		if(!flag)
		{
			printf("%d\n",i);
			break;
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值