AtCoder-4871 Lower

See the original article https://dyingdown.github.io/2019/11/17/AtCoder-4871-Lower/

Lower

Problem Statement

There are N N N squares arranged in a row from left to right.

The height of the i − t h i-th ith square from the left is H i H_i Hi.

You will land on a square of your choice, then repeat moving to the adjacent square on the right as long as the height of the next square is not greater than that of the current square.

Find the maximum number of times you can move.

  • All values in input are integers.
  • 1≤ N N N≤105
  • 1≤ H i H_i Hi≤109

Input

Input is given from Standard Input in the following format:

N
H1 H2 … HN

Output

Print the maximum number of times you can move.

Sample Input 1

5
10 4 8 7 3

Sample Output 1

2

By landing on the third square from the left, you can move to the right twice.

Sample Input 2

7
4 4 5 6 6 5 5

Sample Output 2

3

By landing on the fourth square from the left, you can move to the right three times.

Sample Input 3

4
1 2 3 4

Sample Output 3

0

Analysis

Since the data is small and the time is long, you can use violent methods.

If the this number is no smaller than the previous number, answer = answer + 1;

Else answer = 0

The max number = max(max number, answer).

Code

#include<bits/stdc++.h>

using namespace std;

int main(){
	int n;
	cin >> n;
	int pre = 0, now = 0, count = 0, maxn = 0;
	cin >> pre;
	for(int i = 1; i < n; i ++) {
		cin >> now;
		if(now <= pre) {
			count ++;
		} else {
			maxn = max(maxn, count);
			count = 0;
		}
		pre = now;
	}
	maxn = max(maxn, count);
	cout << maxn << endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值