HDU-1555 How many days?

See the article on https://dyingdown.github.io/2019/12/18/HDU-1555%20How-many-days/

How many days?

The 8600’s mobile phone consumes 1 yuan per day, and every K yuan spent will receive 1 yuan. At the beginning, 8600 has M yuan. How many days can I use?

Input

The input includes multiple test instances. Each test instance includes two integers M, k, (2 <= k <= M <= 1000). M = 0, k = 0 represents the end of the input.

Output

An integer is output for each test instance, which indicates the number of days that M yuan can be used.

Sample Input

2 2
4 3
0 0

Sample Output

3
5

Analysis

This is just stimulation. At first I think the answer was m + m ÷ k m + m \div k m+m÷k . However, I didn’t think of that there may be given more than k days more.

Code

#include<bits/stdc++.h>

using namespace std;

int main() {
	int m, k;
	while(cin >> m >> k, m, k) {
		int count = 0, ik = 0;
		while(m) {
			m --;
			ik ++;
			if(ik % k == 0) {
				m += 1;
				ik = 0;
			}
			count ++;
		} 
		cout << count << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值