POJ 3463 Sightseeing(最短路次短路计数)

87 篇文章 0 订阅

Sightseeing
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9444 Accepted: 3319

Description

Tour operator Your Personal Holiday organises guided bus trips across the Benelux. Every day the bus moves from one city S to another city F. On this way, the tourists in the bus can see the sights alongside the route travelled. Moreover, the bus makes a number of stops (zero or more) at some beautiful cities, where the tourists get out to see the local sights.

Different groups of tourists may have different preferences for the sights they want to see, and thus for the route to be taken from S to F. Therefore, Your Personal Holiday wants to offer its clients a choice from many different routes. As hotels have been booked in advance, the starting city S and the final city F, though, are fixed. Two routes from S to F are considered different if there is at least one road from a city A to a city B which is part of one route, but not of the other route.

There is a restriction on the routes that the tourists may choose from. To leave enough time for the sightseeing at the stops (and to avoid using too much fuel), the bus has to take a short route from S to F. It has to be either a route with minimal distance, or a route which is one distance unit longer than the minimal distance. Indeed, by allowing routes that are one distance unit longer, the tourists may have more choice than by restricting them to exactly the minimal routes. This enhances the impression of a personal holiday.

For example, for the above road map, there are two minimal routes from S = 1 to F = 5: 1 → 2 → 5 and 1 → 3 → 5, both of length 6. There is one route that is one distance unit longer: 1 → 3 → 4 → 5, of length 7.

Now, given a (partial) road map of the Benelux and two cities S and F, tour operator Your Personal Holiday likes to know how many different routes it can offer to its clients, under the above restriction on the route length.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with two integers N and M, separated by a single space, with 2 ≤ N ≤ 1,000 and 1 ≤ M ≤ 10, 000: the number of cities and the number of roads in the road map.

  • M lines, each with three integers AB and L, separated by single spaces, with 1 ≤ AB ≤ NA ≠ B and 1 ≤ L ≤ 1,000, describing a road from city A to city B with length L.

    The roads are unidirectional. Hence, if there is a road from A to B, then there is not necessarily also a road from B to A. There may be different roads from a city A to a city B.

  • One line with two integers S and F, separated by a single space, with 1 ≤ SF ≤ N and S ≠ F: the starting city and the final city of the route.

    There will be at least one route from S to F.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of routes of minimal length or one distance unit longer. Test cases are such, that this number is at most 109 = 1,000,000,000.

Sample Input

2
5 8
1 2 3
1 3 2
1 4 5
2 3 1
2 5 3
3 4 2
3 5 4
4 5 3
1 5
5 6
2 3 1
3 2 1
3 1 10
4 5 2
5 2 7
5 2 7
4 1

Sample Output

3
2

Hint

The first test case above corresponds to the picture in the problem description.

Source


题目大意:

    有一张有向图,最短路和比最短路长1的路径的方案数。


解题思路:

    很容易就想到对最短路和次短路统计方案数,如果两者相差1就把次短路的方案数加到答案中。不过这里说的次短路和大多数情况下说的不一样,一般只要有一条边不同就认为是两条路径,这里指的是长度比最短路长的最短路径。虽然次短路的定义有些差别,但只要在原来求最短路店模板上稍微改一下就可以了。

    为了统计方案数,我们需要额外开一个cnt数组,记录到到某个点的第k短路径数。转移的使用只要多加一个得到的距离和当前相等的时候即可。具体见代码。


AC代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <string>
#include <ctime>
using namespace std;
#define INF 0x3f3f3f3f
#define ULL unsigned long long
#define LL long long
#define fi first
#define se second
#define mem(a, b) memset((a),(b),sizeof(a))

const int MAXV=1000+3;

struct Node
{
    int u, dis, k;
    Node(int u, int d, int k):u(u), dis(d), k(k){}
    bool operator<(const Node &other)const
    {
        return dis>other.dis;
    }
};

vector<pair<int, int> > G[MAXV];//图的邻接表表示,to, cost
int V, E, S, T;
int dist[2][MAXV], cnt[2][MAXV];//到结点i的最短路,次短路距离,方案数
priority_queue<Node> que;
bool vis[2][MAXV];

void init()
{
    for(int i=1;i<=V;++i)
        G[i].clear();
}

void dij()
{
    mem(dist, 0x3f);
    mem(cnt, 0);
    mem(vis, 0);
    while(!que.empty())
        que.pop();
    dist[0][S]=0;
    cnt[0][S]=1;
    que.push(Node(S, 0, 0));
    while(!que.empty())
    {
        Node p=que.top(); que.pop();
        int u=p.u, d=p.dis, k=p.k;
        if(vis[k][u])//防止重复计算
            continue;
        vis[k][u]=true;
        for(int i=0;i<G[u].size();++i)
        {
            int v=G[u][i].fi, d2=d+G[u][i].se;
            if(dist[0][v]>d2)//更新最短路,次短路
            {
                dist[1][v]=dist[0][v];
                cnt[1][v]=cnt[0][v];
                dist[0][v]=d2;
                cnt[0][v]=cnt[k][u];
                que.push(Node(v, dist[0][v], 0));
                que.push(Node(v, dist[1][v], 1));
            }
            else if(dist[0][v]==d2)//增加最短路方案数
                cnt[0][v]+=cnt[k][u];
            else if(dist[1][v]>d2)//更新次短路
            {
                dist[1][v]=d2;
                cnt[1][v]=cnt[k][u];
                que.push(Node(v, dist[1][v], 1));
            }
            else if(dist[1][v]==d2)//增加次短路方案数
                cnt[1][v]+=cnt[k][u];
        }
    }
}

int main()
{
    int T_T;
    scanf("%d", &T_T);
    while(T_T--)
    {
        scanf("%d%d", &V, &E);
        init();
        for(int i=0;i<E;++i)
        {
            int u, v, c;
            scanf("%d%d%d", &u, &v, &c);
            G[u].push_back(make_pair(v, c));
        }
        scanf("%d%d", &S, &T);
        dij();
        if(dist[0][T]+1==dist[1][T])//如果次短路比最短路长1,则加上方案数
            cnt[0][T]+=cnt[1][T];
        printf("%d\n", cnt[0][T]);
    }
    
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值