Poj 2187 Beauty Contest 凸包 求最远顶点对

Beauty Contest
Time Limit: 3000MS
Memory Limit: 65536K
Total Submissions: 28405
Accepted: 8811

Description

Bessie, Farmer John's prize cow, has just won first place in a bovine beauty contest, earning the title 'Miss Cow World'. As a result, Bessie will make a tour of N (2 <= N <= 50,000) farms around the world in order to spread goodwill between farmers and their cows. For simplicity, the world will be represented as a two-dimensional plane, where each farm is located at a pair of integer coordinates (x,y), each having a value in the range -10,000 ... 10,000. No two farms share the same pair of coordinates. 

Even though Bessie travels directly in a straight line between pairs of farms, the distance between some farms can be quite large, so she wants to bring a suitcase full of hay with her so she has enough food to eat on each leg of her journey. Since Bessie refills her suitcase at every farm she visits, she wants to determine the maximum possible distance she might need to travel so she knows the size of suitcase she must bring.Help Bessie by computing the maximum distance among all pairs of farms. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Two space-separated integers x and y specifying coordinate of each farm 

Output

* Line 1: A single integer that is the squared distance between the pair of farms that are farthest apart from each other. 

Sample Input

4
0 0
0 1
1 1
1 0

Sample Output

2

Hint

Farm 1 (0, 0) and farm 3 (1, 1) have the longest distance (square root of 2) 

运用凸包求最远点对,求出凸包之后,用穷举法求出凸包上距离最远的定点对。(注意:最远顶点对一定都在凸包上)

#include <iostream>
#include <cmath>
#include <cstdio>
#include <algorithm>
using namespace std;
#define MAX 50005
struct point {
    int x,y;
}tree[MAX],s[MAX];
int top, n;
int dis(point a,point b)
{
    return (a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y);
}

int chacheng(point a,point b,point c)
{
    return ((a.x-c.x)*(b.y-c.y)-(b.x-c.x)*(a.y-c.y));
}

int cmp(point a,point b)
{
    int k = chacheng(a,b,tree[0]);
    if(k>0)
        return 1;
    else if(k==0 && dis(a,tree[0])<dis(b,tree[0]))
        return 1;
    return 0;
}

void graham()
{
    int i, k=0;
    point temp;
    for(i=1; i<n; i++)
    {
        if(tree[i].y<tree[k].y || ((tree[i].y==tree[k].y)&&(tree[i].x<tree[k].x)))
            k = i;
    }
    temp = tree[0];
    tree[0] = tree[k];
    tree[k] = temp;

    sort(tree+1,tree+n,cmp);
    top=2;
    s[0] = tree[0];
    s[1] = tree[1];
    s[2] = tree[2];
    for(i=3; i<n; i++)
    {
        while(top>1&&chacheng(tree[i],s[top],s[top-1])>=0)
            top--;
        s[++top] = tree[i];
    }
}

int main()
{
    int i, j;
    while (cin>>n)
    {
        for(i=0; i<n; i++)
            cin>>tree[i].x>>tree[i].y;
        graham();
        int Dis = -1;
        for (i=0; i<=top; i++)
            for(j=i+1; j<=top; j++)
            {
                if(Dis<dis(s[i],s[j]))
                    Dis = dis(s[i],s[j]);
            }
        cout<<Dis<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值