Anagrams by Stack

How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT: 

[
i i i i o o o o
i o i i o o i o
]

where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

A stack is a data storage and retrieval structure permitting two operations: 

Push - to insert an item and
Pop - to retrieve the most recently pushed item 
We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence: 

i i o i o o is valid, but 
i i o is not (it's too short), neither is 
i i o o o i (there's an illegal pop of an empty stack) 

Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o o produce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.
 

Input
The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.
 

Output
For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by 

[
]

and the sequences should be printed in "dictionary order". Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.
 

Sample Input
  
  
madam adamm bahama bahama long short eric rice
 

Sample Output
  
  
[ i i i i o o o i o o i i i i o o o o i o i i o i o i o i o o i i o i o i o o i o ] [ i o i i i o o i i o o o i o i i i o o o i o i o i o i o i o i i i o o o i o i o i o i o i o i o ] [ ] [ i i o i o i o o ]
 

dfs思路 先把s1压进,然后逐位比较是否相等,相等则压入o表示弹栈,不等返回,栈的top-1,继续比较s2的下一位。假如所有的位比较完达到字符串长度则输出。否则返回
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;

const int maxn=100;

char x1[maxn];
char s1[maxn];
char s2[maxn];
char stack[maxn];
int len1,len2,len3;

void dfs(int x,int y,int p)
{
    if(y==len2)
    {              
        printf("\n");               
        for(int i=0;i<len3;i++)
            printf("%c ",x1[i]);
    }
    else 
    {   
        if(x<len1)
        {  
            char temp=stack[p];                                                
            x1[len3++]='i';
            stack[p]=s1[x];
            dfs(x+1,y,p+1);
            stack[p]=temp;
            len3--;
        }
        if(p>0&&stack[p-1]==s2[y])
        {
            x1[len3++]='o';                                      
            dfs(x,y+1,p-1);
            len3--;
        }
    }
}
int main()
{
	while(cin>>s1>>s2)
    {                             
        len1=strlen(s1);
        len2=strlen(s2);
        len3=0;
	memset(stack,0,sizeof(stack));
        if(len1!=len2) 
        {
            printf("[\n]\n");
            continue;
        }
        printf("[");
        dfs(0,0,0);
        printf("\n]\n");
    }            
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值