hdu 1018 计算一个数阶乘的位数

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
Output
The output contains the number of digits in the factorial of the integers appearing in the input.
Sample Input
  
  
2 10 20
Sample Output
  
  
7 19

题意:求一个数的阶乘的位数

因为根据数学知识可以知道:

log10(1*2*3*4.........*n)=log10(1)+log10(2)+log10(3)+log10(4)...........+log10(n);

又因为阶乘很可能超出整形,不容易计算,所以就应用log进行计数

#include<stdio.h>
#include<math.h>
int main()
{
    int t,m;
    scanf("%d",&t);
    while(t--)
    {
        double sum=0;
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
         sum+=log10(i);
         printf("%d\n",((int)sum)+1);    
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

洋葱ycy

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值