hdu Children's queue

Children’s Queue

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 75   Accepted Submission(s) : 19
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?

Input

There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)

Output

For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.

Sample Input

1
2
3

Sample Output

1
2
4

题目大意:一个排队游戏,假如有n个人,排成一排,规则:女生必须至少两个站一起,男生随便站。问有多少种站法。

解题思路:此题明显是一个递推问题,在此规定n个人排队共有f(n)种排法。

(1)假如第n个人是男生则有f(n-1)种排法。

(2)若第n个人是女生则第n-1个人一定是女生,此种情况又分两种。一是,若第n-2个人是男生的话,则有f(n-2)。第二种情况,第n-2个人是女生则要满足题意则队形应是

f(n-4)+男+女;

综上所诉此题满足的递推关系式为f(n)=f(n-1)+f(n-2)+f(n-4);

注意此题还涉及到超大数处理。

代码:

#include <stdio.h>
int a[1001][1001]={0};
int main()
{
    int n,m,i,j,t,l;
    a[1][1]=1,a[2][1]=2,a[3][1]=4,a[4][1]=7;
        m=0;

       //把1000以内所有的数据都计算出来,这样就不用每输入一个数都要从a[1]算起,更节省时间。
        for(j=5;j<=1000;j++)
        {
            for(i=0;i<1001;i++)
            {
                m+=a[j-1][i]+a[j-2][i]+a[j-4][i];
                a[j][i]=m%10;//每次磨10取余算出本位的数,放入对应的数组序号里
                m/=10;//求进位数
            }
            while(m)//对最高的一位做特殊处理
            {
                a[j][t++]=m%10;
                m/=10;
            }
        }

    while(scanf("%d",&n)!=EOF)
    {
        for(i=1000;i>=0;i--)//从头找到第一个不为零的数
            if(a[n][i]!=0)
                break;
            printf("%d",a[n][i]);//输出结果
        for(l=i-1;l>=1;l--)
            printf("%d",a[n][l]);
        printf("\n");

    }

return 0;
}

为了进一步节约时间可以采用下面每四位存到一个数组变量里,采用四位四位的输出方法,计算所有的f(n)时每次循环由1001次减少到101次。

代码:

#include <stdio.h>
int a[1001][101]={0};
int main()
{
    int n,m,i,j,t,l;
    a[1][1]=1,a[2][1]=2,a[3][1]=4,a[4][1]=7;
        m=0;
        for(j=5;j<=1000;j++)
        {
            for(i=0;i<101;i++)
            {
                m+=a[j-1][i]+a[j-2][i]+a[j-4][i];
                a[j][i]=m%10000;
                m/=10000;
            }
            while(m)
            {
                a[j][t++]=m%10000;
                m/=10000;
            }
        }

    while(scanf("%d",&n)!=EOF)
    {
        for(i=100;i>=0;i--)
            if(a[n][i]!=0)
                break;
            printf("%d",a[n][i]);
        for(l=i-1;l>=1;l--)
            printf("%04d",a[n][l]);//注意:四位四位的输出格式是%04d
        printf("\n");

    }

return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,HDU1622是一道关于二叉树的题目,要求读入一系列二叉树的节点信息,输出它们的层序遍历结果。如果输入的二叉树不完整或存在重复节点,则输出"not complete"。下面是Java的实现代码: ```java import java.util.LinkedList; import java.util.Queue; import java.util.Scanner; public class Main { static class Node { int val; Node left, right; public Node(int val) { this.val = val; } } public static void main(String[] args) { Scanner sc = new Scanner(System.in); while (sc.hasNext()) { String s = sc.nextLine(); if (s.isEmpty()) { continue; } String[] nodes = s.split("\\s+"); Node root = new Node(Integer.parseInt(nodes[0].substring(1))); Queue<Node> queue = new LinkedList<>(); queue.offer(root); boolean isComplete = true; for (int i = 1; i < nodes.length - 1; i += 2) { Node cur = queue.poll(); if (!nodes[i].equals("()")) { cur.left = new Node(Integer.parseInt(nodes[i].substring(1))); queue.offer(cur.left); } else { isComplete = false; } if (!nodes[i + 1].equals("()")) { cur.right = new Node(Integer.parseInt(nodes[i + 1].substring(0, nodes[i + 1].length() - 1))); queue.offer(cur.right); } else { isComplete = false; } } if (!isComplete) { System.out.println("not complete"); continue; } StringBuilder sb = new StringBuilder(); queue.offer(root); while (!queue.isEmpty()) { Node cur = queue.poll(); sb.append(cur.val).append(" "); if (cur.left != null) { queue.offer(cur.left); } if (cur.right != null) { queue.offer(cur.right); } } System.out.println(sb.toString().trim()); } } } ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值