SDUTOJ 2128 树结构练习——排序二叉树的中序遍历

树结构练习——排序二叉树的中序遍历

Time Limit: 1000MS Memory limit: 65536K

题目描述

在树结构中,有一种特殊的二叉树叫做排序二叉树,直观的理解就是——(1).每个节点中包含有一个关键值 (2).任意一个节点的左子树(如果存在的话)的关键值小于该节点的关键值 (3).任意一个节点的右子树(如果存在的话)的关键值大于该节点的关键值。现给定一组数据,请你对这组数据按给定顺序建立一棵排序二叉树,并输出其中序遍历的结果。
 

输入

输入包含多组数据,每组数据格式如下。
第一行包含一个整数n,为关键值的个数,关键值用整数表示。(n<=1000)
第二行包含n个整数,保证每个整数在int范围之内。

输出

为给定的数据建立排序二叉树,并输出其中序遍历结果,每个输出占一行。
 

示例输入

1
2
2
1 20

示例输出

2
1 20

提示

 

来源

 赵利强

示例程序

 题目已经给出排序二叉树是什么意思了,只需要按照题目要求建树就可以。



示例代码:


#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<string>


using namespace std;


struct node
{
    int data;
    struct node *left,*right;
};


int n;


struct node *creat(struct node *&root,int m)
{
    if(root == NULL)
    {
        root = (struct node*)malloc(sizeof(struct node));
        root->left = NULL;
        root->right = NULL;
        root->data = m;
    }
    else
    {
        if(m < root->data)
        {
            creat(root->left,m);
        }
        else
        {
            creat(root->right,m);
        }
    }
}
int flag = 0;
void zhongxu(struct node *root)
{
    if(root!=NULL)
    {
        zhongxu(root->left);
        if(flag == 0)
        {
            flag = 1;
            printf("%d",root->data);


        }
        else
        {
            printf(" %d",root->data);
        }


        zhongxu(root->right);
    }
}


int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        flag = 0;
        int m;
        struct node *root = NULL;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&m);
            creat(root,m);
        }
        zhongxu(root);
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值