HDU 1757 A Simple Math Problem(矩阵快速幂)

A Simple Math Problem
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Lele now is thinking about a simple function f(x). 

If x < 10 f(x) = x. 
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10); 
And ai(0<=i<=9) can only be 0 or 1 . 

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m. 
 

Input

The problem contains mutiple test cases.Please process to the end of file. 
In each case, there will be two lines. 
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 ) 
In the second line , there are ten integers represent a0 ~ a9. 
 

Output

For each case, output f(k) % m in one line.
 

Sample Input

       
       
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 

Sample Output

       
       
45 104
 

 
 
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

struct node
{
    int mp[15][15];
} init,res;

long long int k,mod;

void chu()
{
    for(int i=0;i<10;i++)
    {
        for(int j=0;j<10;j++)
        {
            if(i == j)
            {
                res.mp[i][j] = 1;
            }
            else
            {
                res.mp[i][j] = 0;
            }
        }
    }
    for(int i=0;i<10;i++)
    {
        for(int j=0;j<10;j++)
        {
            if(i-1 == j)
            {
                init.mp[i][j] = 1;
            }
            else
            {
                init.mp[i][j] = 0;
            }
        }
    }
}

struct node mult(struct node a,struct node b)
{
    struct node c;
    for(int i=0; i<10; i++)
    {
        for(int j=0; j<10; j++)
        {
            c.mp[i][j] = 0;
            for(int k=0; k<10; k++)
            {
                c.mp[i][j] += (a.mp[i][k] * b.mp[k][j])%mod;
                c.mp[i][j] %= mod;
            }
        }
    }
    return c;
} ;

struct node Cal(long long int kk)
{
    struct node tmp = res,x = init;
    while(kk)
    {
        if(kk%2 == 1)
        {
            tmp = mult(x,tmp);
        }
        x = mult(x,x);
        kk>>=1;
    }
    return tmp;
};

int main()
{
    while(~scanf("%lld%lld",&k,&mod))
    {
        chu();
        for(int i=0; i<10; i++)
        {
            scanf("%d",&init.mp[0][i]);
        }
        if(k<10)
        {
            printf("%d\n",k%mod);
            continue;
        }
        struct node tt;
        tt = Cal(k-9);
        int sum = 0;
        for(int i=0; i<10; i++)
        {
            sum += (tt.mp[0][i]*(9-i))%mod;
        }
        printf("%d\n",sum%mod);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值