Given two positive integers a and b,find suitable X and Y to meet the conditions: X+Y=a Least Common Multiple (X, Y) =b
Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.
Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of "No Solution"(without quotation).
Sample Input
6 8 798 10780
Sample Output
No Solution 308 490
题意:找到两个整数x和y,使得 x+y=a 且 lcm(x,y)=b,如果能输出x,y,否者,输出No Solution
思路:
令gcd(x,y)=g;
那么
g * k1 = x
g * k2 = y
由于g是x,y的gcd,则k1和k2互质
>>>>>> g * k1 * k2 = b;
>>>>>> g * k1 + g * k2 = a
>>>>>> k1 * k2 = b/g k1 + k2 = a/g
因为k1,k2互质,则 k1 * k2 与 k1 + k2 互质
则 b/g 与 a/g 互质,则 g = gcd(a,b)
所以 gcd(x,y) = gcd(a,b)
化解 x+y=a 且 lcm(x,y)=b
为一元二次方程: x^2 - ax + b*gcd(a,b)=0;
求解x
代码:
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int Gcd(int x,int y){
while(y){
int z=x%y;
x=y;
y=z;
}
return x;
}
int main(){
int a,b;
while(~scanf("%d%d",&a,&b)){
int gcd=Gcd(a,b);
int det=a*a-4*b*gcd;
if(det<0) printf("No Solution\n");
else{
int p=sqrt(det);
if(p*p!=det) printf("No Solution\n");
else{
int x1=(a+p)/2;
int x2=(a-p)/2;
int x=min(x1,x2);
printf("%d %d\n",x,a-x);
}
}
}
return 0;
}