HDU 5038 Grade(哈希水题)

Grade
Time Limit:1500MS     Memory Limit:262144KB     64bit IO Format:%I64d & %I64u

Description

Ted is a employee of Always Cook Mushroom (ACM). His boss Matt gives him a pack of mushrooms and ask him to grade each mushroom according to its weight. Suppose the weight of a mushroom is w, then it’s grade s is 

s = 10000 - (100 - w)^2

What’s more, Ted also has to report the mode of the grade of these mushrooms. The mode is the value that appears most often. Mode may not be unique. If not all the value are the same but the frequencies of them are the same, there is no mode.
 

Input

The first line of the input contains an integer T, denoting the number of testcases. Then T test cases follow. 

The first line of each test cases contains one integers N (1<=N<=10^6),denoting the number of the mushroom. 

The second line contains N integers, denoting the weight of each mushroom. The weight is greater than 0, and less than 200.
 

Output

For each test case, output 2 lines. 

The first line contains "Case #x:", where x is the case number (starting from 1) 

The second line contains the mode of the grade of the given mushrooms. If there exists multiple modes, output them in ascending order. If there exists no mode, output “Bad Mushroom”.
 

Sample Input

       
       
3 6 100 100 100 99 98 101 6 100 100 100 99 99 101 6 100 100 98 99 99 97
 

Sample Output

       
       
Case #1: 10000 Case #2: Bad Mushroom Case #3: 9999 10000
 




#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

int a[201];
int cnt;
int maxx;

int main()
{
    int T;
    scanf("%d",&T);
    int kk = 0;
    while(T--)
    {
        kk++;
        int n,m,h;
        memset(a,0,sizeof(a));
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&m);
            h = 100 - m;
            if(h<0)
            {
                h = -h;
            }
            a[h]++;
        }
        maxx = 0;
        cnt = 1;
        for(int i=0;i<=200;i++)
        {
            if(a[i]>maxx)
            {
                maxx = a[i];
                cnt = 1;
            }
            else if(a[i] == maxx)
            {
                cnt++;
            }
        }
        printf("Case #%d:\n",kk);
        if(maxx * cnt == n)
        {
            if(cnt == 1)
            {
                for(int i=0;i<200;i++)
                {
                    if(maxx == a[i])
                    {
                        printf("%d\n",10000-i*i);
                    }
                }
            }
            else
            {
                printf("Bad Mushroom\n");
            }
            
        }
        else
        {
            for(int i=200;i>=0;i--)
            {
                if(a[i] == maxx)
                {
                    if(cnt!=1)
                    {
                        printf("%d ",10000-i*i);
                    }
                    else
                    {
                        printf("%d\n",10000-i*i);
                    }
                    cnt--;
                }
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值