HDU 2795 Billboard(简单线段树)

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12812    Accepted Submission(s): 5578


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
 

Author
hhanger@zju
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1698  1542  1828  1540  2871 



    题意: 有一个h*w的木板,要在上面贴广告,有一个要求就是尽可能的贴在上面,如果不能就尽可能的贴在左面,(这样可以使得贴的广告数目最多吧),每个广告都是1*wi,这就说明每一个广告只能占据一行,可以使用线段树进行维护,每次都进行比较,如果最上面剩下的宽度大于或等于广告的宽就减去广告在木板该行的宽度。如果能想起来这种方法就很简单,如果想不出来都不知道怎么做...





#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>
#include<stack>

using namespace std;

const int maxn = 200001;

struct node
{
    int l;
    int r;
    int cnt;
}q[maxn<<4];
int h,w,n;

void build(int l,int r,int rt)
{
    q[rt].l = l;
    q[rt].r = r;
    q[rt].cnt = 0;
    if(q[rt].l == q[rt].r)
    {
        q[rt].cnt = w;
        return ;
    }
    int mid = (l+r)>>1;
    build(l,mid,rt<<1);
    build(mid+1,r,rt<<1|1);
    q[rt].cnt = max(q[rt<<1].cnt,q[rt<<1|1].cnt);
}

int qurry(int k,int l,int r,int rt)
{
    if(q[rt].l == q[rt].r)
    {
        q[rt].cnt -= k;
        return q[rt].l;
    }
    int mid = (l+r)>>1;
    int ans = 0;
    if(q[rt<<1].cnt>=k)
    {
        ans = qurry(k,l,mid,rt<<1);
    }
    else
    {
        ans = qurry(k,mid+1,r,rt<<1|1);
    }
    q[rt].cnt = max(q[rt<<1].cnt,q[rt<<1|1].cnt);
    return ans;
}

int main()
{
    while(scanf("%d%d%d",&h,&w,&n)!=EOF)
    {
        if(h>n)
        {
            h = n;
        }
        build(1,h,1);
        while(n--)
        {
            int m;
            scanf("%d",&m);
            if(m>q[1].cnt)
            {
                printf("-1\n");
            }
            else
            {
                int ans = qurry(m,1,h,1);
                printf("%d\n",ans);
            }

        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值