poj 2299 Ultra-QuickSort(树状数组 / 求逆序数)

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 46080 Accepted: 16763

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source






#include <iostream>
#include <stdio.h>
#include <cmath>
#include<stdlib.h>
#include <algorithm>
#include<string.h>

using namespace std;

int b[500005], c[500005];
int n;

struct node
{
    int num, id;
} a[500005];

bool cmp(node a, node b)
{
    return a.num < b.num;
}

int lowbit(int x)
{
    return x&(-x);
}

void update(int i, int x)
{
    while(i <= n)
    {
        c[i] += x;

        i = i + lowbit(i);

    }
}

int sum(int i)
{

    int sum = 0;
    while(i > 0)
    {
        sum += c[i];
        i = i - lowbit(i);

    }
    return sum;
}

int main()
{
    int i;
    long long ans;
    while(scanf("%d", &n)!=EOF)
    {
        memset(b, 0, sizeof(b));
        memset(c, 0, sizeof(c));
        for(i = 1; i <= n; i++)
        {
            scanf("%d", &a[i].num);
            a[i].id = i;
        }

        sort(a+1, a+n+1, cmp);
        b[a[1].id] = 1;
        for(i = 2; i <= n; i++)
        {
            b[a[i].id] = i;
        }
        ans = 0;
        for(i = 1; i <= n; i++)
        {
            update(b[i], 1);
            ans += (sum(n)-sum(b[i]));
        }
        printf("%lld\n", ans);
    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值