POJ 1836 Alignment(DP max(最长上升子序列 + 最长下降子序列))

Alignment
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 14486 Accepted: 4695

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
• 2 <= n <= 1000 
• the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

Source



    题意:有n个士兵,每个士兵都有一个身高,现在他们按照左右顺序进行站队,求删去最小的士兵数,是的每一个士兵都能通过左边或者右边的无穷远处。

    思路:枚举每一个士兵,算出以他为最长上升子序列的终点,以他的后一个士兵作为最长下降子序列的起点,求出这样的最大值。


#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

#define inf 9999
#define INF -9999

using namespace std;

int n;
double a[1010];
double dp1[1010],dp2[1010];

int res1(int len,double num)
{
    int l = 0;
    int r = len;
    while(l!=r)
    {
        int mid = (l + r) >> 1;
        if(dp1[mid] == num)
        {
            return mid;
        }
        else if(dp1[mid]<num)
        {
            l = mid + 1;
        }
        else
        {
            r = mid;
        }
    }
    return l;
}

int res2(int len,double num)
{
    int l = 0;
    int r = len;
    while(l!=r)
    {
        int mid = (l+r)>>1;
        if(dp2[mid] == num)
        {
            return mid;
        }
        else if(dp2[mid]>num)
        {
            l = mid + 1;
        }
        else
        {
            r = mid;
        }
    }
    return l;
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%lf",&a[i]);
        }
        int len1 = 1,len2 = 1;
        dp1[0] = -99;
        dp2[0] = 99;
        int maxx = -100;
        for(int i=1; i<n; i++)
        {
            int ans = 0;
            len1 = 1;
            dp1[0] = -99;
            for(int j=1; j<=i; j++)
            {
                dp1[i] = inf;
                int k1 = res1(len1,a[j]);
                if(k1 == len1)
                {
                    len1++;
                }
                dp1[k1] = a[j];
            }
            ans = len1 - 1;
            len2 = 1;
            dp2[0] = 99;
            for(int j=i+1; j<=n; j++)
            {
                int t = (j - i);
                dp2[t] = INF;
                int k2 = res2(len2,a[j]);
                if(k2 == len2)
                {
                    len2++;
                }
                dp2[k2] = a[j];
            }
            ans += len2 - 1;
            maxx = max(maxx,ans);
        }
        printf("%d\n",n - maxx);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值