POJ 3273 Monthly Expense(二分)

Monthly Expense
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17465 Accepted: 6961

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers:  N and  M 
Lines 2.. N+1: Line  i+1 contains the number of dollars Farmer John spends on the  ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

Source



   题意:有n份钱,要求分成m组,并且一份不许拆分,要求分成的m组后每一组总的和最小,然后输出这种情况下最大一组的和。

   看懂题后想不出来用二分写,还是做得题少......

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

int n,m;
int num[1000100];
int l,r;

int qurry(int mid)
{
    int p = 1;
    int sum = 0;
    for(int i=0;i<n;i++)
    {
        if((sum+num[i])<=mid)
        {
            sum += num[i];
        }
        else
        {
            sum = num[i];
            p++;
        }
    }
    if(p>m)
    {
        return 0;
    }
    return 1;
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        l = 0;
        r = 0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&num[i]);
            r += num[i];
            if(l<num[i])
            {
                l = num[i];
            }
        }
        int mid = (l+r)/2;
        while(l<r)
        {
            if(qurry(mid))
            {
                r = mid - 1;
            }
            else
            {
                l = mid + 1;
            }
            mid = (l+r)/2;
        }
        printf("%d\n",mid);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值