POJ 1703 Find them, Catch them(并查集拓展)

Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 36534 Accepted: 11209

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.
 
 
 
    题意:在这个城市里有两个黑帮团伙,现在给出N个人,问任意两个人他们是否在同一个团伙
1.输入D x y代表x于y不在一个团伙里
2.输入A x y要输出x与y是否在同一团伙或者不确定他们在同一个团伙里


#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

const int maxn = 100010;

int bin[maxn],family[maxn];
int n,m;

int findx(int x){
    int r;
    if(bin[x]!=x){
        r = findx(bin[x]);
        family[x] = family[x]^family[bin[x]];
        return bin[x] = r;
    }
    return x;
}

void bing(int x,int y){
    int fx = findx(x);
    int fy = findx(y);
    bin[fx] = fy;
    family[fx] = ~(family[y]^family[x]);
}

int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        char str[5];
        int x,y;
        scanf("%d%d",&n,&m);
        for(int i=0;i<=n;i++){
            bin[i] = i;
            family[i] = 0;
        }
        for(int i=0;i<m;i++){
            scanf("%s%d%d",&str,&x,&y);
            if(strcmp(str,"D") == 0){
                bing(x,y);
            }else{
                if(n == 2){
                    printf("In different gangs.\n");
                }else if(findx(x) == findx(y)){
                    if(family[x] == family[y]){
                        printf("In the same gang.\n");
                    }else{
                        printf("In different gangs.\n");
                    }
                }else{
                    printf("Not sure yet.\n");
                }
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值