Co-prime
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2445 Accepted Submission(s): 918
Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10
15) and (1 <=N <= 10
9).
Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
Sample Input
2 1 10 2 3 15 5
Sample Output
Case #1: 5 Case #2: 10HintIn the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.
Source
题意:给出三个整数n,m,k,请输出区间[n,m]中与k互质的个数。
最简单的容斥定理原理,做了这个差不多就理解一点容斥定理的意思了.
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<vector>
#include<queue>
#include<stack>
#include<map>
#define N 1000100
using namespace std;
__int64 n,m,k;
__int64 prime[N],num[N];
int t;
__int64 IEP(__int64 pn){ /// [n,m]区间求与k互质的个数
__int64 pt = 0;
__int64 s = 0;
num[pt++] = -1;
for(__int64 i=0;i<t;i++){
__int64 l = pt;
for(__int64 j=0;j<l;j++){
num[pt++] = num[j]*prime[i]*(-1);
}
}
for(__int64 i=1;i<pt;i++){
s += pn/num[i];
}
return s;
}
int main(){
int T;
int kk = 0;
scanf("%d",&T);
while(T--){
scanf("%I64d%I64d%I64d",&n,&m,&k);
__int64 pk = sqrt(k);
t = 0;
for(int i=2;i<=pk;i++){
if(k%i == 0){
prime[t++] = i;
}
while(k%i == 0){
k = k/i;
}
}
if(k!=1){
prime[t++] = k;
}
__int64 sum = m - n + 1 - IEP(m) + IEP(n-1);
printf("Case #%d: %I64d\n",++kk,sum);
}
return 0;
}