PAT1043 Is It a Binary Search Tree (25)(二叉查找树BST)

类型

二叉搜索树, 先序后序转换

题目

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line “YES” if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or “NO” if not. Then if the answer is “YES”, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO
#分析题目
输入一个先序的树,判断是否为二叉搜索树,或者是否为二叉搜索树的镜像树。

变量意义
root根节点
root + 1左子树第一个结点
tail右子树最后一个结点
i右子树第一个结点
j左子树最后一个结点
isMirror是否为镜像二叉搜索树的flag

利用二叉搜索树的性质:左子树下的所有节点比根节点要小,右子树的所有节点节点比根节点大或者相等

  • 先通过二叉树性质判断是否为先序的二叉搜索树,如果是的话,getpost获得的后序树节点数等于N,否则小于N。
  • 若不为先序的二叉搜索树,则将isMirror设置为true(先假设它是镜像的二叉搜索树),通过二叉树性质(此时左子树节点比根节点大或相等,右子树节点比根节点小)判断是否为镜像二叉搜索树。

代码

#include <iostream>
#include <vector>
using namespace std;
vector<int> pre, post;
int isMirror = 0;
void getpost(int root, int tail)
{
    if(root > tail)
        return;
    int i = root+1;
    int j = tail;
    if(!isMirror)
    {
        while(i<=tail&&pre[i]<pre[root]) i++;
        while(j> root&&pre[j]>=pre[root]) j--;
    }
    else
    {
        while(i<=tail&&pre[i]>=pre[root]) i++;
        while(j>root && pre[j]<pre[root]) j--;
    }
    getpost(root+1, j);
    getpost(i, tail);
    post.push_back(pre[root]);
}

int main()
{
    int N;
    cin >> N;
    pre.resize(N);
    for(int i = 0; i<N; i++)
    {
        cin >> pre[i];
    }
    getpost(0, N-1);
    if(post.size()!=N)
    {
        isMirror = 1;
        post.clear();
        getpost(0, N-1);
    }
    if(post.size() == N)
    {
        cout << "YES" << endl << post[0];
        for(int i=1; i<post.size(); i++)
        {
            cout << " " << post[i];
        }
    }
    else
        cout << "NO" << endl;
    return 0;
}

总结

学习了二叉搜索树的性质,对先序和后序的转化复习了一下,学(chao)习还是来自于柳神的代码

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
图像识别技术在病虫害检测中的应用是一个快速发展的领域,它结合了计算机视觉和机器学习算法来自动识别和类植物上的病虫害。以下是这一技术的一些关键步骤和组成部: 1. **数据收集**:首先需要收集大量的植物图像数据,这些数据包括健康植物的图像以及受不同病虫害影响的植物图像。 2. **图像预处理**:对收集到的图像进行处理,以提高后续析的准确性。这可能包括调整亮度、对比度、去噪、裁剪、缩放等。 3. **特征提取**:从图像中提取有助于识别病虫害的特征。这些特征可能包括颜色、纹理、形状、边缘等。 4. **模型训练**:使用机器学习算法(如支持向量机、随机森林、卷积神经网络等)来训练模型。训练过程中,算法会学习如何根据提取的特征来识别不同的病虫害。 5. **模型验证和测试**:在独立的测试集上验证模型的性能,以确保其准确性和泛化能力。 6. **部署和应用**:将训练好的模型部署到实际的病虫害检测系统中,可以是移动应用、网页服务或集成到智能农业设备中。 7. **实时监测**:在实际应用中,系统可以实时接收植物图像,并快速给出病虫害的检测结果。 8. **持续学习**:随着时间的推移,系统可以不断学习新的病虫害样本,以提高其识别能力。 9. **用户界面**:为了方便用户使用,通常会有一个用户友好的界面,显示检测结果,并提供进一步的指导或建议。 这项技术的优势在于它可以快速、准确地识别出病虫害,甚至在早期阶段就能发现问题,从而及时采取措施。此外,它还可以减少对化学农药的依赖,支持可持续农业发展。随着技术的不断进步,图像识别在病虫害检测中的应用将越来越广泛。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值