PAT 1043 Is It a Binary Search Tree(二叉查找树)

10 篇文章 0 订阅
4 篇文章 0 订阅

1043. Is It a Binary Search Tree (25)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO
题意:给你n个数的顺序作为一棵二叉查找树的输入顺序,问这个顺序是不是该二叉查找树的先序遍历或者是不是该二叉查找树的镜像树的先序遍历。如果符合其中一个要求,输出该二叉树的后序遍历或该二叉树的镜像树的后序遍历。所谓镜像树,顾名思义,很好理解啦,即互为镜像树的两棵树对称,也就是每个节点的左右子节点刚好相反,注意是所有节点,而不单是根节点。那么对镜像树的遍历就只是将对右子树的遍历放在左子树的前面,其他的写法和普通二叉树的写法一样。具体看代码。

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<stack>
#include<iostream>
using namespace std;
#define inf 0x3fffffff
#define LL long long
#define mem(a,b) memset(a,b,sizeof(b))
struct node
{
    int data;
    node *left,*right;
};
void sert(node* &root,int data)//插入数据
{
    if(root==NULL)
    {
        root=new node;
        root->data=data;
        root->left=root->right=NULL;
        return ;
    }
    if(root->data>data) sert(root->left,data);//wa
    else sert(root->right,data);
}
void preorder(node* root,vector<int>&vi)//先序遍历
{
    if(root==NULL) return ;
    vi.push_back(root->data);
    preorder(root->left,vi);
    preorder(root->right,vi);
}
void preom(node* root,vector<int>&vi)//镜像树先序遍历
{
    if(root==NULL) return ;
    vi.push_back(root->data);
    preom(root->right,vi);
    preom(root->left,vi);
}
void postorder(node* root,vector<int>&vi)//后序遍历
{
    if(root==NULL) return ;
    postorder(root->left,vi);
    postorder(root->right,vi);
    vi.push_back(root->data);
}
void postom(node* root,vector<int>&vi)//镜像树后序遍历
{
    if(root==NULL) return ;
    postom(root->right,vi);
    postom(root->left,vi);
    vi.push_back(root->data);
}
vector<int> pre,prem,pos,posm,origin;
int main()
{
    int n,data;
    scanf("%d",&n);
    node* root=NULL;
    for(int i=0;i<n;i++)
    {
        scanf("%d",&data);
        sert(root,data);//建树
        origin.push_back(data);
    }
    preorder(root,pre);//此时的root是已经建好了的树
    preom(root,prem);
    postorder(root,pos);
    postom(root,posm);
    if(origin==pre)//如果数据输入顺序与树的先序遍历相同
    {
        printf("YES\n");
        for(int i=0;i<pos.size();i++)//输出树的后序遍历
        {
            printf("%d",pos[i]);
            if(i<prem.size()-1) printf(" ");
            else printf("\n");
        }
    }
    else if(origin==prem)//如果数据输入的顺序与镜像树的先序遍历顺序相同
    {
        printf("YES\n");
        for(int i=0;i<posm.size();i++)//输出镜像树的后序遍历
        {
            printf("%d",posm[i]);
            if(i<pos.size()-1) printf(" ");
            else printf("\n");
        }
    }
    else printf("NO\n");
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值