PAT - 天梯赛 L2-006 树的遍历

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
4 1 6 3 5 7 2
用递归重建树

#include<cstdio>
#include<queue>
using namespace std;
int hou[31];
int mid[31];
int n;
struct node{
	int l;
	int r;
}tree[31];
int build(int la,int ra,int lb,int rb){//重建tree la,ra代表中序,lb,rb代表后序; 
	if(la>ra)return -1;
	int root=hou[rb],p1,p2;
	p1=la;
	while(mid[p1]!=root)p1++;
	p2=p1-la;//中间节点的左子代个数 
	tree[root].l=build(la,p1-1,lb,lb+p2-1);
	tree[root].r=build(p1+1,ra,lb+p2,rb-1);
	return root;
}
void bfs(int a){
	queue<int>p;
	p.push(a);
	int co=0;
	while(!p.empty()){
		int f=p.front();
		p.pop();
		if(co != n-1){//最后一个不输出空格 
			printf("%d ",f);
			co++;
		}else{
			printf("%d",f);
			return;
		}
		if(tree[f].l!=-1){
			p.push(tree[f].l);
		}
		if(tree[f].r!=-1){
			p.push(tree[f].r);
		}
	}
}
int main(){
	scanf("%d",&n);
	for(int i = 0; i < n; i++){
		scanf("%d", &hou[i]);
	}
	for(int i = 0; i < n; i++){
		scanf("%d", &mid[i]);
	}
	int root=build(0,n-1,0,n-1);
	bfs(root);
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值