Neverending competitions

题目描述

There are literally dozens of snooker competitions held each year, and team Jinotega tries to attend them all (for some reason they prefer name "snookah")! When a competition takes place somewhere far from their hometown, Ivan, Artsem and Konstantin take a flight to the contest and back.

Jinotega's best friends, team Base have found a list of their itinerary receipts with information about departure and arrival airports. Now they wonder, where is Jinotega now: at home or at some competition far away? They know that:

  • this list contains all Jinotega's flights in this year (in arbitrary order),
  • Jinotega has only flown from his hometown to a snooker contest and back,
  • after each competition Jinotega flies back home (though they may attend a competition in one place several times),
  • and finally, at the beginning of the year Jinotega was at home.

Please help them to determine Jinotega's location!

输入描述

In the first line of input there is a single integer n: the number of Jinotega's flights (1 ≤ n ≤ 100). In the second line there is a string of 3 capital Latin letters: the name of Jinotega's home airport. In the next n lines there is flight information, one flight per line, in form "XXX->YYY", where "XXX" is the name of departure airport "YYY" is the name of arrival airport. Exactly one of these airports is Jinotega's home airport.

It is guaranteed that flights information is consistent with the knowledge of Jinotega's friends, which is described in the main part of the statement.

输出描述

If Jinotega is now at home, print "home" (without quotes), otherwise print "contest".

样例输入

4
SVO
SVO->CDG
LHR->SVO
SVO->LHR
CDG->SVO

样例输出

home

提示

In the sample Jinotega might first fly from SVO to CDG and back, and then from SVO to LHR and back, so now they should be at home.

#include<bits/stdc++.h>
using namespace std;
int main()
{
  int n;
  cin>>n;
  int a=n;
  getchar();
  string sk;
  while(a--)getline(cin,sk);
  if(n%2==0) cout<<"home\n";
  else cout<<"contest\n";
}

#include<bits/stdc++.h>
using namespace std;
int main()
{
  int n,con=0;
  cin>>n;
  string home,stl,ss;
  getchar();
  getline(cin,home);
  while(n--)
  {
    getline(cin,stl);
    ss=stl.substr(0,3);
    if(home==ss)
    {
      con++;
    }
    ss=stl.substr(5,3);
    if(home==ss)
    {
      con--;
    }
  }
  
  if(con==0)cout<<"home";
  else
  cout<<"contest";
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

反手敲代码

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值