Your name【NEUQ OJ 1552】

题目描述

 Recently,plyjdz was asked by many friends about his girl friend.But in some reason,plyjdz thinks he doesn't have one.One day,he finds a note on his table but he can't understand it.Can you tell him what the note means?

输入描述

You will get the note which is a string(length<=50).
*This note includes 'a'-'z','A'-'Z',numbers,and symbols

输出描述

If the note include "pyd",you should tell plyjdz "Her name is pyd"
If not,you should teel tell plyjdz"You should wait"
*pyd may be divided by numbers,'A'-'Z'or symbols.

样例输入

asdafx2131.23cvipydhnifw
safiowefo328ru91oa.f,m
saifojergov[p21p.1yd
dafaofj817dypoi.13awo

样例输出

Her name is pyd
You should wait
Her name is pyd
You should wait
#include<bits/stdc++.h>
using namespace std;
int main()
{
	string skl,s;
	while(getline(cin,skl,'\n'))
	{
		for(int i=0;i<skl.size();i++)
			if(skl[i]=='p'||skl[i]=='y'||skl[i]=='d')
				s=s+skl[i];
		int a=0;
		a=s.find("pyd");
		if(a!=-1)
			printf("Her name is pyd\n");
		else
		printf("You should wait\n");
			skl.clear();s.clear(); 
		}
		
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

反手敲代码

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值