长L米,宽W米的草坪里装有n个浇灌喷头。每个喷头都装在草坪中心线上(离两边各W/2米)。我们知道每个喷头的位置(离草坪中心线左端的距离),以及它能覆盖到的浇灌范围。
请问:如果要同时浇灌整块草坪,最少需要打开多少个喷头?
输入格式:
输入包含若干组测试数据。
第一行一个整数T表示数据组数。
每组数据的第一行是整数n、L和W的值,其中n≤10 000。
接下来的n行,每行包含两个整数,给出一个喷头的位置和浇灌半径。
如图1所示的示意图是样例输入的第一组数据所描述的情况。
图1
输出格式:
对每组测试数据输出一个数字,表示要浇灌整块草坪所需喷头数目的最小值。如果所有喷头都打开还不能浇灌整块草坪,则输出-1。
输入样例:
3
8 20 2
5 3
4 1
1 2
7 2
10 2
13 3
16 2
19 4
3 10 1
3 5
9 3
6 1
3 10 1
5 3
1 1
9 1
输出样例:
6
2
-1
数据范围与提示:
对于100%的数据,n≤15000。
#include<iostream>
#include<algorithm>
#include<cstring>
#include<iomanip>
#include<cmath>
#include<vector>
#include<stack>
using namespace std;
int main()
{
int T;cin>>T;
//Sprinkler head,用first保存左端点,用second保存右端点
vector< pair<double,double> > sh;
pair<double,double> p;
while(T--)
{
int n,L;double W;
cin>>n>>L>>W;
sh.clear();
for(int i=1;i<=n;i++)
{
int x;double r;
cin>>x>>r;
if(r<W/2) continue;
r=sqrt(r*r-(W/2)*(W/2));
p=make_pair(x-r,x+r);
sh.push_back(p);
}
sort(sh.begin(),sh.end());//左端点非递减,若左端相同则右端点非递减(其实右端点怎样排序无所谓)
int i=0,ans=0;
double t=0;//t是已灌溉区域的右端点
bool flag=1;
while(i<sh.size())
{
if(t<sh[i].first) {flag=0;break;}//中间有一段不能完全覆盖
if(t>=L) break;//已经完全覆盖
double max_r=-1;
while(i<sh.size()&&t>=sh[i].first)//在可选范围中选取右端点最大的
{
max_r=max(max_r,sh[i].second);
i++;
}
t=max_r;
ans++;
}
if(flag) cout<<ans<<endl;
else cout<<"-1"<<endl;
}
}