Grading

46 篇文章 0 订阅
46 篇文章 0 订阅
题目描述:

    Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam problem to 3 independent experts. If they do not agree to each other, a judge is invited to make the final decision. Now you are asked to write a program to help this process.
    For each problem, there is a full-mark P and a tolerance T(<P) given. The grading rules are:
    • A problem will first be assigned to 2 experts, to obtain G1 and G2. If the difference is within the tolerance, that is, if |G1 - G2| ≤ T, this problem's grade will be the average of G1 and G2.
    • If the difference exceeds T, the 3rd expert will give G3.
    • If G3 is within the tolerance with either G1 or G2, but NOT both, then this problem's grade will be the average of G3 and the closest grade.
    • If G3 is within the tolerance with both G1 and G2, then this problem's grade will be the maximum of the three grades.
    • If G3 is within the tolerance with neither G1 nor G2, a judge will give the final grade GJ.

输入:

    Each input file may contain more than one test case.
    Each case occupies a line containing six positive integers: P, T, G1, G2, G3, and GJ, as described in the problem. It is guaranteed that all the grades are valid, that is, in the interval [0, P].

输出:

    For each test case you should output the final grade of the problem in a line. The answer must be accurate to 1 decimal place.

样例输入:
20 2 15 13 10 18
样例输出:
14.0
import java.util.Scanner;
 
public class Main{
 
    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
        double grade = 0.0;
        int P = -1,T = -1,G1 = -1,G2 = -1,G3 = -1,GJ = -1;
        while( scanner.hasNext() ){
            P = scanner.nextInt();
            T = scanner.nextInt();
            G1 = scanner.nextInt();
            G2 = scanner.nextInt();
            G3 = scanner.nextInt();
            GJ = scanner.nextInt();
             
            if(G1<0 ||  G2<0 || G3<0 || GJ < 0 || G1>P ||  G2>P || G3>P || GJ>P ){
                break;
            }
             
            if(Math.abs(G1-G2) <= T ){
                grade =(G1+G2)/2.0;
                System.out.println(grade);
                continue;
            }
             
             
                 
            if(Math.abs(G3-G1) <= T && Math.abs(G3-G2) <= T){
                grade = ((G1>G2?G1:G2)>G3?(G1>G2?G1:G2):G3)/1.0;
                System.out.println(grade);
                continue;
                 
            }
             
            if(Math.abs(G3-G1) > T && Math.abs(G3-G2) > T){
                 
                grade = GJ/1.0;
                System.out.println(grade);
                continue;
                 
            }
             
            if(Math.abs(G3-G2) <=T && Math.abs(G3-G1) >T){
                    grade = (G3+G2)/2.0;
                    System.out.println(grade);
                    continue;
            }
             
            if(Math.abs(G3-G1) <=T && Math.abs(G3-G2) >T){
                grade = (G3+G1)/2.0;
                System.out.println(grade);
                continue;
            }
        }
    }
 
 
}
 
/**************************************************************
    Problem: 1002
    User: yihukurama
    Language: Java
    Result: Accepted
    Time:100 ms
    Memory:17512 kb
****************************************************************/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值