【欧拉降幂公式+快速幂】HDU_4704_Sum

Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 3440    Accepted Submission(s): 1408


Problem Description
 

Sample Input
  
  
2
 

Sample Output
  
  
2
Hint
1. For N = 2, S(1) = S(2) = 1. 2. The input file consists of multiple test cases.
 

Source
 

Recommend
zhuyuanchen520
 
/*
隔板法推出答案为2^(n-1)%(1e9+7)
*/
#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const int maxn=1e5+10;
const long long mod=1e9+7;
char s[maxn];
LL quickpow(LL x,LL a){
    LL ans=1;
    while(a){
        if(a&1)
            ans=ans*x%mod;
        x=x*x%mod;
        a>>=1;
    }
    return ans;
}
int main()
{
    while(~scanf("%s",s)){
        int len=strlen(s);
        LL phi=mod-1;
        LL n=0;
        for(int i=0;i<len;i++)
            n=(n*10+s[i]-'0')%phi;
        n=(n-1+phi)%phi+phi;
        printf("%I64d\n",quickpow(2,n));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值