HDU-1241 Oil Deposits

6 篇文章 0 订阅
4 篇文章 0 订阅

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.


Input The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
Output For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

Sample Output

0
1
2
2

题意:@表示是一块油田,但多个@相连视为一处油田,题目要求找出所给实例有多少油田。题目中的油田即为连通块,用DFS(递归)求出连通块的数量。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int n,m,ans,a[105][105],f1[8]={1,1,0,-1,-1,-1,0,1},f2[8]={0,-1,-1,-1,0,1,1,1};//两个数组分别代表8个方向
char str[105][105];

void dfs(int x,int y){//DFS实际上是一个递归的过程
	int t,p;
	a[x][y]=1;//访问了标记为1
	for(int i=0;i<8;i++){//访问它的8个方向
		t=x+f1[i];p=y+f2[i];
		if((t>=0&&t<n)&&(p>=0&&p<m)&&(str[t][p]=='@')&&(a[t][p]==0)){//三个条件:没有出界,是油田(即为@),未被访问过
			dfs(t,p);
	}
	}	
}

int main(){
	while(~scanf("%d%d",&n,&m),m){
		ans=0;
		memset(a,0,sizeof(a));
		/*for(int i=0;i<n;i++){
			char c=getchar();//读入换行符
			for(int j=0;j<m;j++){
			scanf("%c",&str[i][j]);
			}
		}
		*/
		for(int i=0;i<n;i++){//推荐使用这种方式,可避免读入换行符的问题
			scanf("%s",str[i]);
		}
		for(int i=0;i<n;i++){
			for(int j=0;j<m;j++){
				if((str[i][j]=='@')&&(a[i][j]==0)){//若出现@且没有被搜索过
					ans++;dfs(i,j);//只要找到一个没有被访问过的@,ans++,并且进行搜索
				}
			}
		}
		printf("%d\n",ans);//ans定义为全局变量
	}
	return 0; 
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值